aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/c.scm34
1 files changed, 32 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3b20e84a91..2629ebb6dd 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -38,7 +38,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml))
(define-public tcc
(package
@@ -257,3 +258,32 @@ typing conventions?
every project that needs to deal with sizes in bytes. It is written in the C
language with thin bindings for other languages.")
(license license:lgpl2.1+)))
+
+(define-public udunits
+ (package
+ (name "udunits")
+ (version "2.2.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.unidata.ucar.edu/pub/udunits/"
+ "udunits-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0v9mqw4drnkzkm57331ail6yvs9485jmi37s40lhvmf7r5lli3rn"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("expat" ,expat)))
+ (home-page "https://www.unidata.ucar.edu/software/udunits/")
+ (synopsis "C library for units of physical quantities and value-conversion utils")
+ (description
+ "The UDUNITS-2 package provides support for units of physical quantities.
+Its three main components are:
+
+@enumerate
+@item @code{udunits2lib}, a C library for units of physical quantities;
+@item @code{udunits2prog}, a utility for obtaining the definition of a unit
+ and for converting numeric values between compatible units; and
+@item an extensive database of units.
+@end enumerate\n")
+ ;; Like the BSD-3 license but with an extra anti patent clause.
+ (license (license:non-copyleft "file://COPYRIGHT"))))
accd13c51e6177071ec6df49'>Set Emacs indentation for `wrap-program'....Taylan Ulrich B 2015-02-02tests: Add 'with-derivation-substitute' and use it....Ludovic Courtès 2015-02-02tests: Further factorize substitute mocks....Ludovic Courtès 2015-01-17monads: Add the state monad....Ludovic Courtès 2014-12-02monads: Add 'mwhen' and 'munless'....Ludovic Courtès 2014-10-17derivations: Introduce 'graft' record type....Ludovic Courtès 2014-10-12Augment '.dir-locals.el' with bug-reference-mode settings.Ludovic Courtès 2014-10-08monads: Add 'mbegin'....Ludovic Courtès 2014-10-05build-system: Introduce "bags" as an intermediate representation....Ludovic Courtès 2014-08-18gexp: Add 'ungexp-native' and 'ungexp-native-splicing'....Ludovic Courtès 2014-08-14Add (guix build emacs-utils)....Mark H Weaver 2014-05-03system: Add first-class file system declarations....Ludovic Courtès 2014-04-28Add (guix gexp)....Ludovic Courtès 2014-03-31pki: Add 'signature-case' macro....Ludovic Courtès 2014-03-24utils: Add 'call-with-decompressed-port' and 'call-with-compressed-output-port'....Ludovic Courtès 2014-01-24store: Add 'with-store' convenience macro....Ludovic Courtès 2013-12-29Move 'with-atomic-file-output' to (guix utils)....Ludovic Courtès 2013-11-07Add indentation rule for 'origin'.Ludovic Courtès 2013-11-01guix package: Allow removal of a specific package output....Ludovic Courtès 2013-10-29Change indentation rule for 'package' for the common case....Mark H Weaver 2013-10-03Add (guix monads)....Ludovic Courtès 2013-05-14substitute-binary: Work around thread-unsafe `regexp-exec'....Ludovic Courtès 2013-02-01Augment `.dir-locals.el'....Ludovic Courtès 2013-01-30.dir-locals.el: Fill at 78 columns.Ludovic Courtès 2012-11-01Add (guix ui)....Ludovic Courtès 2012-09-26distro: Add the `guile', `typesetting', and `databases' package modules....Ludovic Courtès