aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/databases.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ab9180bbc4..49840c23fd 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -662,6 +662,29 @@ replacement for the code@{python-memcached} library.")
"This is a memcache client library for the Go programming language.")
(license license:asl2.0)))
+(define-public go-github-com-couchbase-gomemcached
+ (package
+ (name "go-github-com-couchbase-gomemcached")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/couchbase/gomemcached")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10w74gc05x5naspls39sv2r92krrg31mk266w3lyqqwc0s3fxysl"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/couchbase/gomemcached"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/couchbase/gomemcached")
+ (synopsis "Memcached binary protocol toolkit for go")
+ (description
+ "This package provides memcache client and server functionality.")
+ (license license:expat)))
+
(define-public litecli
(package
(name "litecli")
tch_DATA): Register them. * gnu/packages/jami.scm (jami-apply-custom-patches): Delete procedure. (%ffmpeg-default-configure-flags): Delete variable. (ffmpeg-compose-configure-flags): Delete procedure. (ffmpeg-jami): Move to... * gnu/packages/video.scm (ffmpeg-jami): ... here. Apply patches to origin and repatriate configure flags. Change-Id: Id374fae18240cd76b224915d80b61422635ccb77 Maxim Cournoyer 2024-01-09gnu: ffmpeg-jami: Update configure flags....* gnu/packages/jami.scm (%ffmpeg-default-configure-flags): Add new flags. Change-Id: I1bac70e7b0ec58c46348a7138f7260b40cdf79f8 Maxim Cournoyer 2024-01-09gnu: pjproject-jami: Update and relocate....* gnu/packages/jami.scm (pjproject-jami): Move to... * gnu/packages/telephony.scm (pjproject-jami): ... here. Update to latest commit. [arguments]: Use same configure flags as done in Jami/DhtNet projects. Change-Id: I638364ebc94f17762ee072311b5fe439b7c6f837 Maxim Cournoyer