aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-12 21:58:57 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:40 +0000
commit8bea1e05fac2e24ac926f155d76e42aa90690467 (patch)
tree0f9ad155931e331afed5d083d4bb19777a9aba16 /tests
parenta8d5d087086da0e47700781ff858d3d0d2090271 (diff)
downloadguix-8bea1e05fac2e24ac926f155d76e42aa90690467.tar.gz
guix-8bea1e05fac2e24ac926f155d76e42aa90690467.zip
gnu: packages/golang-crypto: Apply #:subdir parameter.
* gnu/packages/golang-crypto.scm (go-github-com-decred-dcrd-crypto-blake256, go-github-com-decred-dcrd-dcrec-secp256k1-v4) [source]: Apply new <#:subdir> parameter for monorepo projects. Change-Id: I85004b257c767ce202129e621d78b285d4578f7a
Diffstat (limited to 'tests')
0 files changed, 0 insertions, 0 deletions
37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 2ea66acc56..b8f416117d 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -408,6 +408,43 @@ JupyterLab. It is a separate project in order to accommodate creating
JupyterLab-like applications from a more limited scope.")
(license license:bsd-3)))
+(define-public python-jupyter-events
+ (package
+ (name "python-jupyter-events")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_events" version))
+ (sha256
+ (base32 "08jyhj16drl3hg594gr677bc5q991lpd4khlhb3jx26csclq42v7"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; This passes the whole command line to shutil.which, instead of just
+ ;; the executable.
+ (list #:test-flags '(list "--ignore=tests/test_cli.py")))
+ (propagated-inputs (list python-jsonschema
+ python-json-logger
+ python-pyyaml
+ python-referencing
+ python-rich
+ python-rfc3339-validator
+ python-rfc3986-validator
+ python-traitlets))
+ (native-inputs (list python-click
+ python-hatchling
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-console-scripts))
+ (home-page "https://pypi.org/project/jupyter-events/")
+ (synopsis "Jupyter Event System library")
+ (description "Jupyter Events enables Jupyter Python
+Applications (e.g. Jupyter Server, JupyterLab Server, JupyterHub, etc.) to
+emit events—structured data describing things happening inside the
+application. Other software (e.g. client applications like JupyterLab) can
+listen and respond to these events.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-packaging
(package
(name "python-jupyter-packaging")