aboutsummaryrefslogtreecommitdiff
path: root/tests/texlive.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-24 02:25:23 -0500
committerMark H Weaver <mhw@netris.org>2018-01-24 05:59:01 -0500
commit52009dc3bd98ea0b3dc0cedaddf4c1a9cf18a2f3 (patch)
treea1b03833adcbd7f710e7563ca584b126ec4f8def /tests/texlive.scm
parentc1c2e1d72b23f57ff0d4869a6970183d833383fb (diff)
downloadguix-52009dc3bd98ea0b3dc0cedaddf4c1a9cf18a2f3.tar.gz
guix-52009dc3bd98ea0b3dc0cedaddf4c1a9cf18a2f3.zip
gnu: icecat: Add more fixes from upstream mozilla-esr52.
Includes fixes for CVE-2018-5104, CVE-2018-5097, CVE-2018-5099, and the remaining 7 out of 21 changesets for CVE-2018-5089. * gnu/packages/gnuzilla.scm (icecat)[source]: Add selected fixes from the upstream mozilla-esr52 repository. Remove the local spectre mitigation patch in favor of the (identical) changeset from upstream. * gnu/packages/patches/icecat-bug-1427870-spectre-mitigation.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'tests/texlive.scm')
0 files changed, 0 insertions, 0 deletions
s b/lib/compress.js
index 5879b93b..bbd3659d 100644
--- a/lib/compress.js
+++ b/lib/compress.js
@@ -970,6 +970,11 @@ merge(Compressor.prototype, {
node.DEFMETHOD("is_string", func);
});
+ function isLHS(node, parent) {
+ return parent instanceof AST_Unary && (parent.operator === "++" || parent.operator === "--")
+ || parent instanceof AST_Assign && parent.left === node;
+ }
+
function best_of(ast1, ast2) {
return ast1.print_to_string().length >
ast2.print_to_string().length
@@ -2608,14 +2613,6 @@ merge(Compressor.prototype, {
});
OPT(AST_SymbolRef, function(self, compressor){
- function isLHS(symbol, parent) {
- return (
- parent instanceof AST_Binary &&
- parent.operator === '=' &&
- parent.left === symbol
- );
- }
-
if (self.undeclared() && !isLHS(self, compressor.parent())) {
var defines = compressor.option("global_defs");
if (defines && HOP(defines, self.name)) {
diff --git a/lib/scope.js b/lib/scope.js
index 4943b568..bc5db90d 100644
--- a/lib/scope.js
+++ b/lib/scope.js
@@ -220,7 +220,7 @@ AST_Toplevel.DEFMETHOD("figure_out_scope", function(options){
sym = g;
}
node.thedef = sym;
- if (parent instanceof AST_Unary && (parent.operator === '++' || parent.operator === '--')
+ if (parent instanceof AST_Unary && (parent.operator === "++" || parent.operator === "--")
|| parent instanceof AST_Assign && parent.left === node) {
sym.modified = true;
}