aboutsummaryrefslogtreecommitdiff
path: root/tests/sets.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-20 22:02:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-20 22:02:59 +0300
commit7f43bc68396a18095651072b047609f639094f49 (patch)
tree4f4a06729c5c35158aec603c36fd094180638540 /tests/sets.scm
parent3f403bb750ad8efd584dfa881e164ef26d2eb8e1 (diff)
downloadguix-7f43bc68396a18095651072b047609f639094f49.tar.gz
guix-7f43bc68396a18095651072b047609f639094f49.zip
gnu: rust-openssl-0.7: Skip build.
* gnu/packages/crates-io.scm (rust-openssl-0.7)[arguments]: Skip build. Remove tests keyword. [inputs]: Remove openssl-1.0.
Diffstat (limited to 'tests/sets.scm')
0 files changed, 0 insertions, 0 deletions
f='/guix/tree/gnu/packages/geo.scm?id=d7552c36ce79dcef8ebc3f7ac97d23e9be9e9859'>gnu/packages/geo.scm
@@ -2826,6 +2826,36 @@ coordinates of addresses, cities, countries, and landmarks across the globe
using third-party geocoders and other data sources.")
(license license:expat)))
+(define-public python-haversine
+ (package
+ (name "python-haversine")
+ (version "2.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; There are no tests in the PyPi archive.
+ (url "https://github.com/mapado/haversine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0inxyj5n4jzgg5xiadqx9sk83gdx5ff989l9s04smdzbd3b8c0c8"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-numpy))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (home-page "https://github.com/mapado/haversine")
+ (synopsis "Calculate the distance between 2 points on Earth")
+ (description "This package provides functions to calculate the
+distance in various units between two points on Earth using their
+latitude and longitude.")
+ (license license:expat)))
+
(define-public gplates
(package
(name "gplates")