aboutsummaryrefslogtreecommitdiff
path: root/tests/offload.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-06 09:03:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-06 09:03:24 +0200
commit36fd42ded23eb2c066a8b25b0f1567c2286b61c1 (patch)
tree5589075937b7782c0c661b420724973fcbfed6f8 /tests/offload.scm
parent7fd2c9a00e8f915d214a2831045c06f51995f62e (diff)
downloadguix-36fd42ded23eb2c066a8b25b0f1567c2286b61c1.tar.gz
guix-36fd42ded23eb2c066a8b25b0f1567c2286b61c1.zip
gnu: emacs-elfeed-score: Update to 0.7.9.
* gnu/packages/emacs-xyz.scm (emacs-elfeed-score): Update to 0.7.9.
Diffstat (limited to 'tests/offload.scm')
0 files changed, 0 insertions, 0 deletions
c620af2'>gnu/packages/web.scm
@@ -7952,6 +7952,40 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+(define-public binaryen
+ (package
+ (name "binaryen")
+ (version "112")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/binaryen")
+ (commit (string-append "version_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0970iz22yjxgi27d67kwmrx4zq7hig3i6b92vmlp4c4bd1bacny5"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'use-system-googletest
+ (lambda _
+ (substitute* "third_party/CMakeLists.txt"
+ ((" googletest/.*") "")
+ (("add_library\\(gtest.*") ""))
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(test/gtest\\)")
+ "find_package(GTest REQUIRED)")))))))
+ (native-inputs (list googletest))
+ (home-page "https://github.com/WebAssembly/binaryen")
+ (synopsis "Optimizer and compiler/toolchain library for WebAssembly")
+ (description "Binaryen is a compiler and toolchain infrastructure library
+for WebAssembly, written in C++. It aims to make compiling to WebAssembly
+easy, fast, and effective.")
+ (license license:asl2.0)))
+
(define-public buku
(package
(name "buku")