aboutsummaryrefslogtreecommitdiff
path: root/tests/hash.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 11:41:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 18:23:46 +0100
commit98516883927f39073360adbdc5ab25e16248e297 (patch)
tree36bb3402c045e6bb8bf8c9716bbbd342b23ef913 /tests/hash.scm
parentf3fda2980cd6c6cb1911c278c45e40efd81c5163 (diff)
downloadguix-98516883927f39073360adbdc5ab25e16248e297.tar.gz
guix-98516883927f39073360adbdc5ab25e16248e297.zip
gnu: python-betamax: Update to 0.8.1.
* gnu/packages/python-web.scm (python-betamax): Update to 0.8.1.
Diffstat (limited to 'tests/hash.scm')
0 files changed, 0 insertions, 0 deletions
=eba493b369e3353d757a82e116682fdd5ea90b47'>gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29425,6 +29425,32 @@ simple mock/record and a complete capture/replay framework.")
interfaces.")
(license license:bsd-3)))
+(define-public python-ordered-set
+ (package
+ (name "python-ordered-set")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ordered-set" version))
+ (sha256
+ (base32 "1a34fg3r3480nfm6652kyqql3lwixf8jirzdja9camvnr128wjk9"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-cython python-pytest))
+ (home-page "https://github.com/simonpercivall/orderedset")
+ (synopsis "Ordered Set implementation in Cython")
+ (description "This library provides an @code{OrderedSet} data type that
+works like a regular set, but remembers insertion order. It supports the full
+Python @code{set} interface.")
+ (license license:asl2.0)))
+
(define-public python-orgparse
(package
(name "python-orgparse")