aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-build-branch.sh
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-10 10:48:59 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-10 10:49:42 +0100
commit0b5ad0e756a34d5e3ed1f37c3d4083a330fa33f5 (patch)
treea425745c27d087db3f011bd8ff9c9e4c105e0370 /tests/guix-build-branch.sh
parentdb1adb424217999d7f51daa7798c521edb66ad40 (diff)
downloadguix-0b5ad0e756a34d5e3ed1f37c3d4083a330fa33f5.tar.gz
guix-0b5ad0e756a34d5e3ed1f37c3d4083a330fa33f5.zip
tests: processes: Skip tests if running with binfmt.
* tests/processes.scm (binfmt-misc?): New procedure, (test-assert*): new procedure that skips the test if binfmt-misc? returns
Diffstat (limited to 'tests/guix-build-branch.sh')
0 files changed, 0 insertions, 0 deletions
-rw-r--r--gnu/packages/c.scm2
-rw-r--r--gnu/packages/cmake.scm6
-rw-r--r--gnu/packages/commencement.scm6
-rw-r--r--gnu/packages/cross-base.scm6
-rw-r--r--gnu/packages/djvu.scm57
-rw-r--r--gnu/packages/ebook.scm8
-rw-r--r--gnu/packages/education.scm4
-rw-r--r--gnu/packages/emacs-xyz.scm44
-rw-r--r--gnu/packages/emacs.scm32
-rw-r--r--gnu/packages/finance.scm57
-rw-r--r--gnu/packages/games.scm122
-rw-r--r--gnu/packages/graph.scm7
-rw-r--r--gnu/packages/haskell-check.scm27
-rw-r--r--gnu/packages/haskell-xyz.scm35
-rw-r--r--gnu/packages/lean.scm7
-rw-r--r--gnu/packages/libusb.scm4
-rw-r--r--gnu/packages/linphone.scm15
-rw-r--r--gnu/packages/linux.scm6
-rw-r--r--gnu/packages/mail.scm37
-rw-r--r--gnu/packages/messaging.scm6
-rw-r--r--gnu/packages/music.scm117
-rw-r--r--gnu/packages/package-management.scm12
-rw-r--r--gnu/packages/patches/openssh-fix-ssh-copy-id.patch38
-rw-r--r--gnu/packages/patches/python-aiohttp-3.6.2-no-warning-fail.patch34
-rw-r--r--gnu/packages/php.scm4
-rw-r--r--gnu/packages/python-compression.scm4
-rw-r--r--gnu/packages/python-web.scm49
-rw-r--r--gnu/packages/python-xyz.scm114
-rw-r--r--gnu/packages/security-token.scm4
-rw-r--r--gnu/packages/shells.scm4
-rw-r--r--gnu/packages/ssh.scm3
-rw-r--r--gnu/packages/video.scm9
-rw-r--r--gnu/packages/web.scm4
-rw-r--r--guix/scripts/deploy.scm33
-rw-r--r--guix/ui.scm1
38 files changed, 616 insertions, 325 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 360c022b95..72c3d43254 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -27951,7 +27951,7 @@ over HTTP.
@deftp {Data Type} git-http-configuration
Data type representing the configuration for a future
@code{git-http-service-type}; can currently be used to configure Nginx
-trough @code{git-http-nginx-location-configuration}.
+through @code{git-http-nginx-location-configuration}.
@table @asis
@item @code{package} (default: @var{git})
diff --git a/etc/news.scm b/etc/news.scm
index 1144ec36c8..9fabb8ff45 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -19,7 +19,8 @@
(version 0)
(entry (commit "a9a2fdaabcc78e7a54d9a6bcfa4ee3de308e9a90")
- (title (en "Logical Volume Manager (LVM) now supported on Guix System"))
+ (title (en "Logical Volume Manager (LVM) now supported on Guix System")
+ (de "Logical Volume Manager (LVM) wird jetzt auf Guix System unterstützt"))
(body
(en "On Guix System, the new @code{lvm-device-mapping} variable
allows you to declare ``mapped devices'' for LVM, the Linux Logical Volume
@@ -33,7 +34,21 @@ group ``vg0'' can be declared as follows:
(type lvm-device-mapping))
@end lisp
-See @command{info \"(guix) Mapped Devices\"} for more information.")))
+See @command{info \"(guix) Mapped Devices\"} for more information.")
+ (de "Auf Guix System erlaubt Ihnen die neue Variable
+@code{lvm-device-mapping}, „zugeordnete Geräte“ (Mapped Devices) für LVM, den
+Linux Logical Volume Manager, zu deklarieren. Zum Beispiel können logische
+Datenträger von LVM namens „alpha“ und „beta“ aus der
+Datenträgergruppe (Volume Group) „vg0“ wie folgt deklariert werden:
+
+@lisp
+(mapped-device
+ (source \"vg0\")
+ (target (list \"vg0-alpha\" \"vg0-beta\"))
+ (type lvm-device-mapping))
+@end lisp
+
+Siehe @command{info \"(guix.de) Zugeordnete Geräte\"} für nähere Informationen.")))
(entry (commit "3b6e4e5fd05e72b8a32ff1a2d5e21464260e21e6")
(title (en "List of substitute keys is now declarative on Guix System")
diff --git a/gnu/local.mk b/gnu/local.mk
index 7717793984..2e802680f8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1409,6 +1409,7 @@ dist_patch_DATA = \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \
+ %D%/packages/patches/openssh-fix-ssh-copy-id.patch \
%D%/packages/patches/openssh-hurd.patch \
%D%/packages/patches/openresolv-restartcmd-guix.patch \
%D%/packages/patches/openscad-parser-boost-1.72.patch \
@@ -1507,7 +1508,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-fix-tests.patch \
%D%/packages/patches/python-3.8-fix-tests.patch \
%D%/packages/patches/python-CVE-2018-14647.patch \
- %D%/packages/patches/python-aiohttp-3.6.2-no-warning-fail.patch \
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
%D%/packages/patches/python-axolotl-AES-fix.patch \
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c49c311fd0..7a7408b4d7 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -184,6 +184,8 @@ language with thin bindings for other languages.")
(define-public udunits
(package
(name "udunits")
+ ;; Four-part version numbers are development snapshots, not releases. See
+ ;; <https://github.com/Unidata/UDUNITS-2/issues/99#issuecomment-732323472>.
(version "2.2.26")
(source (origin
(method url-fetch)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index f4b138ebb3..2f8d50451e 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -297,7 +297,7 @@ and workspaces that can be used in the compiler environment of your choice.")
(package
(inherit cmake-minimal)
(name "cmake")
- (version "3.19.0")
+ (version "3.19.1")
;; TODO: Move the following source field to the cmake-bootstrap package in
;; the next rebuild cycle.
(source (origin
@@ -307,7 +307,7 @@ and workspaces that can be used in the compiler environment of your choice.")
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "14zlrb7awiazxc5wlvgah9rw1dm4ziczbxiyqsvp4zmaan0ninpx"))
+ "1fisi9rlijw9wd0yjzk1c6j7ljnb2yiq5iqnrz6m1xkflyinw9hx"))
(snippet
(match (origin-snippet (package-source cmake-bootstrap))
((_ _ exp ...)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 0938bc3d46..432910d7a3 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm