aboutsummaryrefslogtreecommitdiff
path: root/tests/combinators.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 17:33:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 18:01:18 +0200
commit2f9891725d3c375134b0d8e97e0033df1fe516da (patch)
tree30d8bce8aa611e29d7952b28fec919ca37939b73 /tests/combinators.scm
parent9aba9b127840a116c806a2cbac901cf8077abcd0 (diff)
downloadguix-2f9891725d3c375134b0d8e97e0033df1fe516da.tar.gz
guix-2f9891725d3c375134b0d8e97e0033df1fe516da.zip
gnu: perl-file-mimeinfo: Update to 0.29.
* gnu/packages/freedesktop.scm (perl-file-mimeinfo): Update to 0.29.
Diffstat (limited to 'tests/combinators.scm')
0 files changed, 0 insertions, 0 deletions
n.sh"
(("^unset RETCODE")
- "exit 77\n")))) ;skip
+ "exit 77\n")) ;skip
+ #$@(if (target-ppc32?)
+ ;; https://gitlab.com/gnutls/gnutls/-/issues/1354
+ ;; Extend the test timeout from the default of 20 * 1000
+ #~((add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (setenv "GNUTLS_TEST_TIMEOUT" "60000"))))
+ #~())))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
;; Copy the 4.1 MiB of section 3 man pages to "doc".
@@ -263,18 +270,18 @@ living in the same process.")
(mkdir-p mandir)
(copy-recursively oldman mandir)
(delete-file-recursively oldman)))))))
- (outputs '("out" ;4.4 MiB
+ (outputs '("out" ;4.4 MiB
"debug"
- "doc")) ;4.1 MiB of man pages
+ "doc")) ;4.1 MiB of man pages
(native-inputs
(append (list pkg-config texinfo which
- util-linux) ;one test needs 'setsid'
+ util-linux) ;one test needs 'setsid'
(if (hurd-target?)
'()
(list net-tools
- iproute ;for 'ss'
- socat ;several tests rely on it
- datefudge)))) ;tests rely on 'datefudge'
+ iproute ;for 'ss'
+ socat ;several tests rely on it
+ datefudge)))) ;tests rely on 'datefudge'
(inputs (list libunistring))
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.