aboutsummaryrefslogtreecommitdiff
path: root/srfi
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-15 03:29:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-15 03:45:56 +0100
commit68c10f31f912688fc0d6204cd9b44ba462e83b20 (patch)
treec9b28bf77c5504d33f5e5ba7eb43a02ec7ec5cd3 /srfi
parent708e76287c8181f75052314cf9f0330b19b2a238 (diff)
downloadguix-68c10f31f912688fc0d6204cd9b44ba462e83b20.tar.gz
guix-68c10f31f912688fc0d6204cd9b44ba462e83b20.zip
gnu: conky: Update to 1.10.6.
* gnu/packages/conky.scm (conky): Update to 1.10.6.
Diffstat (limited to 'srfi')
0 files changed, 0 insertions, 0 deletions
s='none' style='width: 96.6%;'/> -rw-r--r--gnu/packages/patches/python-waitress-fix-tests.patch29
-rw-r--r--gnu/packages/python.scm5
3 files changed, 33 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 846de07a5d..19062df6a2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1041,6 +1041,7 @@ dist_patch_DATA = \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
+ %D%/packages/patches/python-waitress-fix-tests.patch \
%D%/packages/patches/qemu-CVE-2017-15038.patch \
%D%/packages/patches/qemu-CVE-2017-15289.patch \
%D%/packages/patches/qt4-ldflags.patch \
diff --git a/gnu/packages/patches/python-waitress-fix-tests.patch b/gnu/packages/patches/python-waitress-fix-tests.patch
new file mode 100644
index 0000000000..110492a604
--- /dev/null
+++ b/gnu/packages/patches/python-waitress-fix-tests.patch
@@ -0,0 +1,29 @@
+Skip test that requires getaddrinfo(), which is not available in the build
+environment. This package uses a regexp for finding tests (see runner.py),
+so using @unittest.skip does not work.
+
+--- a/waitress/tests/test_adjustments.py
++++ b/waitress/tests/test_adjustments.py
+@@ -185,22 +185,6 @@
+ def test_bad_port(self):
+ self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
+
+- def test_service_port(self):
+- if WIN and PY2: # pragma: no cover
+- # On Windows and Python 2 this is broken, so we raise a ValueError
+- self.assertRaises(
+- ValueError,
+- self._makeOne,
+- listen='127.0.0.1:http',
+- )
+- return
+-
+- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
+-
+- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
+-
+- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
+-
+ def test_dont_mix_host_port_listen(self):
+ self.assertRaises(
+ ValueError,
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6e5e804c34..257489d09b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm