aboutsummaryrefslogtreecommitdiff
path: root/nix/scripts
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 13:18:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 13:18:47 +0100
commitbee7bb315cd0b4529a4117b6220c29ca297fc023 (patch)
treefe4741f257e50782e51bc2955ad4480cd2ba6396 /nix/scripts
parentc2f0e5a44b537632c2655f97a2539c3bf02c8a63 (diff)
parent8a4644336d5063fd0bf43e90e3c0823c76e82e4e (diff)
downloadguix-bee7bb315cd0b4529a4117b6220c29ca297fc023.tar.gz
guix-bee7bb315cd0b4529a4117b6220c29ca297fc023.zip
Merge branch 'master' into core-updates
Diffstat (limited to 'nix/scripts')
0 files changed, 0 insertions, 0 deletions
td> -rw-r--r--gnu/packages/patches/python-keras-integration-test.patch19
3 files changed, 21 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 01ec94484f..35775041b8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1225,6 +1225,7 @@ dist_patch_DATA = \
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
%D%/packages/patches/python-faker-fix-build-32bit.patch \
+ %D%/packages/patches/python-keras-integration-test.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e3c69948e2..3eeb9cb1e2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1853,6 +1853,7 @@ with image data, text data, and sequence data.")
(origin
(method url-fetch)
(uri (pypi-uri "Keras" version))
+ (patches (search-patches "python-keras-integration-test.patch"))
(sha256
(base32
"1j8bsqzh49vjdxy6l1k4iwax5vpjzniynyd041xjavdzvfii1dlh"))))
diff --git a/gnu/packages/patches/python-keras-integration-test.patch b/gnu/packages/patches/python-keras-integration-test.patch
new file mode 100644
index 0000000000..aa2b1a273d
--- /dev/null
+++ b/gnu/packages/patches/python-keras-integration-test.patch
@@ -0,0 +1,19 @@
+Fix a test failure with recent versions of ... Pytest? Python?
+
+Taken from upstream:
+https://github.com/keras-team/keras/commit/fe35050a8f18dc52304aa8da4e463eececa25240
+
+diff --git a/tests/integration_tests/applications_test.py b/tests/integration_tests/applications_test.py
+index 979f2f2abd6..6e3b57fa8e2 100644
+--- a/tests/integration_tests/applications_test.py
++++ b/tests/integration_tests/applications_test.py
+@@ -58,7 +58,8 @@ def _test_application_basic(app, last_dim=1000):
+ def _test_application_notop(app, last_dim):
+ output_shape = _get_output_shape(
+ lambda: app(weights=None, include_top=False))
+- assert output_shape == (None, None, None, last_dim)
++ assert len(output_shape) == 4
++ assert output_shape[-1] == last_dim
+
+
+ def test_mobilenet_v2_legacy_import():