aboutsummaryrefslogtreecommitdiff
path: root/m4/guix.m4
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-06 13:37:10 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:38:00 +0100
commit4d9c5984fee481d74c2f504094b4797bbb4104d4 (patch)
treea5011e48f764fbe3fd3c041964b410cb6a5fbe9d /m4/guix.m4
parentec8a5ec15f898e864705e5a5c834532e3fa8d0a4 (diff)
downloadguix-4d9c5984fee481d74c2f504094b4797bbb4104d4.tar.gz
guix-4d9c5984fee481d74c2f504094b4797bbb4104d4.zip
gnu: bootstrap: Add support for x86_64-gnu, aka the 64bit Hurd.
On commit: ec8a5ec15f898e864705e5a5c834532e3fa8d0a4 gnu: make-bootstrap: Update gcc-static to gcc-14, for the 64bit Hurd. Run: ./pre-inst-env guix build --target=x86_64-gnu bootstrap-tarballs Producing: /gnu/store/w1n7bdpn88plcc49h7n0jriaj41sgwx8-bootstrap-tarballs-0/ With guix hash -r: 15cb1xh7s2hhp8s0d81bjnw1759w9sh7ckc9n5jq2f3rqw6z76by * gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for x86_64-gnu. (%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Add entry for x86_64-gnu. * guix/packages.scm (%supported-systems, %hurd-systems): Add x86_64-gnu. (%cuirass-supported-systems): Remove x86_64-gnu. * guix/utils.scm (target-64bit?): Add x86_64-gnu. * m4/guix.m4: Add x86_64-gnu as a supported system. * doc/guix.texi (GNU Distribution): Add x86_64-gnu. Change-Id: I828159aedb3f66caba98e935083cc3682429f219
Diffstat (limited to 'm4/guix.m4')
-rw-r--r--m4/guix.m412
1 files changed, 9 insertions, 3 deletions
diff --git a/m4/guix.m4 b/m4/guix.m4
index b93daba5c3..8c2757a8b7 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -3,6 +3,7 @@ dnl Copyright © 2012, 2013, 2014, 2015, 2016, 2018, 2019, 2020, 2021 Ludovic Co
dnl Copyright © 2014 Mark H Weaver <mhw@netris.org>
dnl Copyright © 2017, 2020, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
dnl Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
+dnl Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
dnl
dnl This file is part of GNU Guix.
dnl
@@ -61,8 +62,13 @@ AC_DEFUN([GUIX_SYSTEM_TYPE], [
linux-musl*)
guix_system="$machine_name-linux";;
gnu*)
- # Always use i586 for GNU/Hurd.
- guix_system="i586-gnu";;
+ case "$machine_name" in
+ i386|i486|i586|i686)
+ # Always use i586 for 32bit GNU/Hurd.
+ guix_system="i586-gnu";;
+ *)
+ guix_system="$machine_name-gnu";;
+ esac;;
*)
# Strip the version number from names such as `gnu0.3',
# `darwin10.2.0', etc.
@@ -91,7 +97,7 @@ courageous and port the GNU System distribution to it (see
# Currently only Linux-based systems are supported, and only on some
# platforms.
case "$guix_system" in
- x86_64-linux|i686-linux|armhf-linux|aarch64-linux|powerpc64le-linux|riscv64-linux|i586-gnu)
+ x86_64-linux|i686-linux|armhf-linux|aarch64-linux|powerpc64le-linux|riscv64-linux|i586-gnu|x86_64-gnu)
;;
mips64el-linux|powerpc-linux)
AC_MSG_WARN([building Guix on `$guix_system', which is not supported])