aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 21:04:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:21 +0100
commitff0d59239194a859414225aaf63cf31b153a63e0 (patch)
treebbd128fc8d949bf72073399559e9d7ea497c9caf /gnu
parentaccf3136a03af88a2717ee78b7b26f25c0ea4597 (diff)
downloadguix-ff0d59239194a859414225aaf63cf31b153a63e0.tar.gz
guix-ff0d59239194a859414225aaf63cf31b153a63e0.zip
gnu: Add python-devpi-common.
* gnu/packages/python-web.scm (python-devpi-common): New variable. Change-Id: I9deef7d64b0c6d2c212dddd3ca3113b3f3dd1082
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1edd3256b1..7fb04659fd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -143,6 +143,31 @@
#:use-module (gnu packages)
#:use-module (srfi srfi-1))
+(define-public python-devpi-common
+ (package
+ (name "python-devpi-common")
+ (version "4.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "devpi_common" version))
+ (sha256
+ (base32 "1k217b0fvsc7k2afw6wwlvqr1ksnv1vjzfm61g358vn98nd0lni3"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-lazy python-packaging-legacy
+ python-requests))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/devpi/devpi")
+ (synopsis
+ "Utilities jointly used by devpi-server, devpi-client and others")
+ (description
+ "This package provides utilities jointly used by devpi-server,
+devpi-client and others.")
+ (license license:expat)))
+
(define-public python-huggingface-hub
(package
(name "python-huggingface-hub")