aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2024-09-19 16:38:38 +0900
committerLudovic Courtès <ludo@gnu.org>2024-09-19 14:32:44 +0200
commitfee669e2c2e49fff7d51c16c09122e239593be20 (patch)
tree75daffa479f60d0a7bb9b30004618d50be4835fc /gnu
parentad6deff8bb47bc4dd637d4612fb4d93055e99fb7 (diff)
downloadguix-fee669e2c2e49fff7d51c16c09122e239593be20.tar.gz
guix-fee669e2c2e49fff7d51c16c09122e239593be20.zip
gnu: make-libiberty: Build with -fPIC.
Since iberty is a static library, linking a PIC-enabled target to it requires it to also have been built with PIC. (The target is Dyninst in this case.) This `-fPIC' flag is appended to the default CFLAGS of `-O2 -g'. * gnu/packages/gcc.scm (make-libiberty)[arguments]: Adjust make-flags to add -fPIC to CFLAGS. Change-Id: I155045d05f4434cb68be933a95b7bc9fdec98818 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 164c8d782c..7fceb4be96 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1065,6 +1065,7 @@ using compilers other than GCC."
(name "libiberty")
(arguments
`(#:out-of-source? #t
+ #:make-flags '("CFLAGS=-O2 -g -fPIC")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'chdir