aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-12-08 17:55:43 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-18 22:57:10 +0800
commitfdfff1079117516327196a51ff82c8f45dc4145c (patch)
tree7e33ef4ae6cdc24a6a488d6828ca5f18ed0aba07 /gnu
parent0ef86deaa6c3ac77b1946037312445ac0be389c9 (diff)
downloadguix-fdfff1079117516327196a51ff82c8f45dc4145c.tar.gz
guix-fdfff1079117516327196a51ff82c8f45dc4145c.zip
gnu: Add papersway.
* gnu/packages/wm.scm (papersway): New variable. Change-Id: I36b21a08fb86d0b8ca526ef5c9b2946e3caa3729
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 204e1f46c2..580b33f4be 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -615,6 +615,43 @@ the i3 window manager through its i3bar component, as an alternative to
i3status.")
(license license:gpl3+)))
+(define-public papersway
+ (package
+ (name "papersway")
+ (version "1.004")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SP/SPWHITTON/App-papersway-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "02p144cbzi3vk5jpk1pmcrf51mmli0q92hrkjyalj91drl0d44px"))))
+ (build-system perl-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda _
+ (for-each
+ (lambda (command)
+ (wrap-program (string-append #$output "/bin/" command)
+ `("PERL5LIB" ":" prefix
+ (,(getenv "PERL5LIB")
+ ,(string-append #$output "/lib/perl5/site_perl")))))
+ '("papersway" "papersway-msg")))))))
+ (inputs (list perl-anyevent perl-anyevent-i3 perl-json))
+ (home-page "https://spwhitton.name/tech/code/papersway/")
+ (synopsis
+ "Scrollable tiling window management for Sway and i3 window manager")
+ (description
+ "@command{papersway} is an implementation of scrollable window management
+like @code{gnome-shell-extension-paperwm} for @code{sway} and @code{i3-wm}.
+If you like @code{sway} and @code{i3-wm}'s commitments to stability, avoiding
+scope creep etc., but dislike the window management model, @command{papersway}
+might be of interest.")
+ (license license:gpl3)))
+
(define-public perl-anyevent-i3
(package
(name "perl-anyevent-i3")