aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-11 19:53:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-11 20:01:53 +0100
commitfb94174fc39cfbdddf23aa58a12b1ee62674122d (patch)
tree63557e6b09352c8171f97b02f710613232018bd7 /gnu
parent531afc8a892512487251a03be24d9833b86179f1 (diff)
downloadguix-fb94174fc39cfbdddf23aa58a12b1ee62674122d.tar.gz
guix-fb94174fc39cfbdddf23aa58a12b1ee62674122d.zip
gnu: Add pigx-bsseq.
* gnu/packages/bioinformatics.scm (pigx-bsseq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 50d3568987..567dd2c24b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12791,3 +12791,67 @@ addition to quality control of the experiment, the pipeline enables to set up
multiple peak calling analysis and allows the generation of a UCSC track hub
in an easily configurable manner.")
(license license:gpl3+)))
+
+(define-public pigx-bsseq
+ (package
+ (name "pigx-bsseq")
+ (version "0.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
+ "releases/download/v" version
+ "/pigx_bsseq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h8ma99vi7hs83nafvjpq8jmaq9977j3n11c4zd95hai0cf7zxmp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-timezone
+ ;; The readr package is picky about timezones.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZ" "UTC+1")
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t))
+ (add-after 'install 'wrap-executable
+ ;; Make sure the executable finds all R modules.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/pigx-bsseq")
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
+ `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
+ #t)))))
+ (native-inputs
+ `(("tzdata" ,tzdata)))
+ (inputs
+ `(("r-minimal" ,r-minimal)
+ ("r-annotationhub" ,r-annotationhub)
+ ("r-dt" ,r-dt)
+ ("r-genomation" ,r-genomation)
+ ("r-methylkit" ,r-methylkit)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-bookdown" ,r-bookdown)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggbio" ,r-ggbio)
+ ("ghc-pandoc" ,ghc-pandoc)
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
+ ("python-wrapper" ,python-wrapper)
+ ("python-pyyaml" ,python-pyyaml)
+ ("snakemake" ,snakemake)
+ ("bismark" ,bismark)
+ ("fastqc" ,fastqc)
+ ("bowtie" ,bowtie)
+ ("trim-galore" ,trim-galore)
+ ("cutadapt" ,cutadapt)
+ ("samtools" ,samtools)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Bisulfite sequencing pipeline from fastq to methylation reports")
+ (description "PiGx BSseq is a data processing pipeline for raw fastq read
+data of bisulfite experiments; it produces reports on aggregate methylation
+and coverage and can be used to produce information on differential
+methylation and segmentation.")
+ (license license:gpl3+)))
2018-11-18activation: Aways pass '-d HOME' to 'useradd'....Fixes <https://bugs.gnu.org/33422>. Reported by fps. * gnu/build/activation.scm (add-user): Always pass "-d HOME" when HOME is true. Pass "--create-home" only when HOME, CREATE-HOME?, and SYSTEM? are true. (activate-users+groups): Pass #:create-home? create-home? to 'ensure-user'. * gnu/tests/base.scm (run-basic-test)["accounts"]: Test 'passwd:dir' as well. Ludovic Courtès 2018-03-27activation: Pass '-d HOME' to 'usermod'....Fixes a bug whereby changes to user home directories in the OS config would never be effective. Reported by Pierre Neidhardt <ambrevar@gmail.com>. * gnu/build/activation.scm (modify-user): Pass '-d HOME'. Ludovic Courtès 2017-10-08activation: Do not create setuid binaries in the store [security fix]....Fixes <https://bugs.gnu.org/28751>. * gnu/build/activation.scm (activate-setuid-programs)[link-or-copy]: Remove. Use 'copy-file' instead. Ludovic Courtès 2017-08-03activation: Make sure /etc exists....Fixes <http://bugs.gnu.org/27146>. Reported by ng0 <ng0@pragmatique.xyz>. * gnu/build/activation.scm (activate-etc): Add call to 'mkdir-p'. Ludovic Courtès 2017-05-30activation: Change permissions on /root to #o700....Reported by Alex Griffin <a@ajgrf.com>. Fixes <http://bugs.gnu.org/27135>. * gnu/build/activation.scm (add-user): When UID is zero, add 'chmod' call. * gnu/tests/base.scm (run-basic-test)["permissions on /root"]: New test. Ludovic Courtès 2017-05-18services: user-homes: Do not create home directories marked as no-create....Fixes a bug whereby GuixSD would create the /nonexistent directory, from user 'nobody', even though it has 'create-home-directory?' set to #f. * gnu/build/activation.scm (activate-users+groups): Add comment for \#:create-home?. (activate-user-home)[ensure-user-home]: Skip when CREATE-HOME? is #f or SYSTEM? is #t. * gnu/tests/base.scm (run-basic-test)["no extra home directories"]: New tests. Ludovic Courtès 2017-02-10Merge branch 'master' into core-updatesLudovic Courtès 2017-02-08services: Add 'special-files-service-type'....* gnu/build/activation.scm (activate-/bin/sh): Remove. (activate-special-files): New procedure. * gnu/services.scm (activation-script): Remove call to 'activate-/bin/sh'. (special-files-service-type): New variable. (extra-special-file): New procedure. * gnu/services/base.scm (%base-services): Add SPECIAL-FILES-SERVICE-TYPE instance. * gnu/tests/base.scm (run-basic-test)[special-files]: New variables. ["special files"]: New test. Ludovic Courtès 2017-02-04activation: Set the right owner for home directories....This fixes a regression introduced in ae763b5b0b7d5e7316a3d0efe991fe8ab2261031 whereby home directories and skeletons would be root-owned. * gnu/build/activation.scm (copy-account-skeletons): Make 'directory' a keyword parameter. Add #:uid and #:gid and honor them. [set-owner]: New procedure. (activate-user-home): Add call to 'getpw' and 'chown'. Pass UID and GID to 'copy-account-skeletons'. * gnu/tests/base.scm (run-basic-test)["skeletons in home directories"]: Test file ownership under HOME. Ludovic Courtès 2017-02-02Merge branch 'master' into core-updatesLeo Famulari 2017-02-01system: Create home directories once 'file-systems' is up....Fixes <http://bugs.gnu.org/21108>. Reported by Andy Patterson <ajpatter@uwaterloo.ca> and Leo Famulari <leo@famulari.name>. * gnu/build/activation.scm (activate-users+groups)[activate-user]: Pass #:create-home? #t iff CREATE-HOME? and SYSTEM?. (activate-user-home): New procedure. * gnu/system/shadow.scm (account-shepherd-service): New procedure. (account-service-type)[extensions]: Add SHEPHERD-ROOT-SERVICE-TYPE extension. * gnu/tests/base.scm (run-basic-test)["home"] ["skeletons in home directories"]: New tests. * gnu/tests/install.scm (%separate-home-os, %separate-home-os-source) (%test-separate-home-os): New variables. Ludovic Courtès 2017-01-26utils: Add helper method to make files writable....* gnu/build/activation.scm (make-file-writable): Move this to ... * guix/build/utils.scm (make-file-writable): ... here. Export it. * guix/build/gnu-build-system.scm (strip): Use it. Marius Bakke 2016-09-06activation: Don't fail if /var/lib exists....This is a followup to commit 6526d43ea4fb0cd151a0d5e9a072c651c1c963d1. * gnu/build/activation.scm (activate-user+groups): Use mkdir-p to create /var/lib. Leo Famulari 2016-09-06activation: Allow home directories to be created under /var/lib....* gnu/build/activation.scm (activate-user+groups): Make sure /var/lib exists. David Craven 2016-08-28system: Add 'create-home-directory?' field to <user-account>....* gnu/system/shadow.scm (<user-account>)[create-home-directory?]: New field. (user-account->gexp): Serialize it. * gnu/build/activation.scm (activate-users+groups)[activate-user]: Update 'match-lambda' pattern accordingly. Pass #:create-home? to 'ensure-user'. (add-user, modify-user, ensure-user): Add #:create-home? parameter and honor it. * doc/guix.texi (User Accounts): Document it. Ludovic Courtès 2016-03-24activation: Copy account skeletons silently....* gnu/build/activation.scm (copy-account-skeletons): Pass #:log to 'copy-recursively'. Ludovic Courtès 2016-03-20system: Allow account skeletons to be directories....* gnu/system/shadow.scm (skeleton-directory): Use 'copy-recursively' instead of 'copy-file'. * gnu/build/activation.scm (copy-account-skeletons): Likewise. Ludovic Courtès