aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 17:33:07 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-12 09:04:07 -0500
commitfb6a1ff921199280e160e20966b665d2302497f1 (patch)
treeacbaf360bb78287c037fa47f54553a94bbcba9c1 /gnu
parent4fb525dff294a7c5c81fcdefab60c38f719b6e95 (diff)
downloadguix-fb6a1ff921199280e160e20966b665d2302497f1.tar.gz
guix-fb6a1ff921199280e160e20966b665d2302497f1.zip
gnu: appstream-glib: Propagate gdk-pixbuf+svg rather than gdk-pixbuf.
Propagating gdk-pixbuf rather than gdk-pixbuf+svg is dangerous as it clashes with GTK+'s own gdk-pixbuf+svg propagation. * gnu/packages/glib.scm (appstream-glib)[propagated-inputs]: Replace gdk-pixbuf by gdk-pixbuf+svg.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 9cc2b1b69e..8de6e198be 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -1001,7 +1001,7 @@ Some codes examples can be find at:
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("gcab" ,gcab) ; for .pc file
- ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
+ ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for .pc file
("libuuid" ,util-linux "lib"))) ; for .pc file
(inputs
`(("glib" ,glib)