aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-07-24 21:02:34 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:43 +0200
commitf9f49a70f21d24fbddab839b281978a963cff797 (patch)
treebaf6fac1a355e16989a1ee7141ccdb2709e0198c /gnu
parent95db62d87de43fd67226e95efc694dd4eb59832d (diff)
downloadguix-f9f49a70f21d24fbddab839b281978a963cff797.tar.gz
guix-f9f49a70f21d24fbddab839b281978a963cff797.zip
gnu: lib2geom: Disable broken test on aarch64.
* gnu/packages/graphics.scm (lib2geom)[arguments]: Conditionally disable "elliptical-arc-test". Change-Id: Id6bbcb9c94831daa65c9596f080c194392d08b42
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 1801853175..2e67adab89 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -920,16 +920,24 @@ exception-handling library.")
(("PYTHON_LIB_INSTALL \"[^\"]*\"")
(format #f "PYTHON_LIB_INSTALL ~s"
(python:site-packages inputs outputs))))))
- #$@(if (target-x86-32?)
- #~((add-after 'unpack 'skip-faulty-test
- (lambda _
- ;; This test fails on i686 when comparing floating point
- ;; values, probably due to excess precision. However,
- ;; '-fexcess-precision' is not implemented for C++ in
- ;; GCC 10 so just skip it.
- (substitute* "tests/CMakeLists.txt"
- (("bezier-test") "")))))
- #~()))))
+ #$@(cond
+ ((target-x86-32?)
+ #~((add-after 'unpack 'skip-faulty-test
+ (lambda _
+ ;; This test fails on i686 when comparing floating point
+ ;; values, probably due to excess precision. However,
+ ;; '-fexcess-precision' is not implemented for C++ in
+ ;; GCC 10 so just skip it.
+ (substitute* "tests/CMakeLists.txt"
+ (("bezier-test") ""))))))
+ ;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
+ ((target-aarch64?)
+ #~((add-after 'unpack 'fix-aarch64-faulty-test
+ (lambda _
+ (substitute* "tests/CMakeLists.txt"
+ (("elliptical-arc-test") ""))))))
+ (else
+ #~())))))
(native-inputs (list python-wrapper googletest pkg-config))
(inputs (list cairo python-pycairo double-conversion glib gsl))
(propagated-inputs (list boost)) ;included in 2geom/pathvector.h
(string-match/newline "^constraint from www.gnu.org$" config) (string-match/newline "^server 0.guix.pool.ntp.org$" config) (string-match/newline "^constraints from \"https://www.google.com/\"$" config) ;; Check for issue #3731 (see: ;; http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37318). (= (match-count "^listen on " config) 2) (= (match-count "^sensor " config) 1) (= (match-count "^constraint from " config) 1) (= (match-count "^server " config) 2) (= (match-count "^constraints from " config) 1))) (begin (format #t "The configuration below failed \ the sanity check:\n~a~%" config) #f) #t)))) (test-equal "openntpd generated config string ends with a newline" "\n" (let ((config (openntpd-configuration->string %openntpd-conf-sample))) (string-take-right config 1))) (test-end "networking")