aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-03 17:43:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 17:45:48 +0200
commitf821c06b676074c37451501e661515020a0a8b9a (patch)
tree2f3d727bb17807480159e5d9be9ddb2f3fb2e2da /gnu
parentc66e5ef5f9b184b0abb882b0cce7c7d19e02f30d (diff)
downloadguix-f821c06b676074c37451501e661515020a0a8b9a.tar.gz
guix-f821c06b676074c37451501e661515020a0a8b9a.zip
gnu: Add python-astroml.
* gnu/packages/astronomy.scm (python-astroml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cdb6750f09..1dca667ef0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages libevent)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -463,6 +464,45 @@ in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public python-astroml
+ (package
+ (name "python-astroml")
+ (version "1.0.2.post1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "astroML" version))
+ (sha256
+ (base32
+ "14g2mcd5qdr3nn7icvjs84bjvx17l9glx81sbbna6v53i1x8l625"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "--ignore-glob=examples/*")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-build-system
+ (lambda _
+ (substitute* "setup.cfg"
+ ;; Do not error out on deprecations
+ ((" error::DeprecationWarning.*") "")
+ ;; Do not test examples
+ (("testspaths = astroML doc examples")
+ "testspaths = astroML"))))
+ (add-before 'check 'pre-check
+ ;; Some tests need this
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list python-astropy python-matplotlib python-numpy
+ python-scikit-learn python-scipy))
+ (native-inputs (list python-pytest-astropy-header python-pytest-cov
+ python-pytest-doctestplus python-pytest-remotedata))
+ (home-page "https://astroml.org")
+ (synopsis "Tools for machine learning and data mining in astronomy")
+ (description "This package provides tools for machine learning and data
+mining in astronomy.")
+ (license license:bsd-2)))
+
(define-public python-fitsio
(package
(name "python-fitsio")