aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-28 08:52:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:40 +0000
commitf62a9caa367ba9cd8824699fe1ae8787a2784cd1 (patch)
tree7994213c42c8d31e1898763af1afd8798fed0d17 /gnu
parente0759d8413f5d2ccb880ab895c70bc33d266d1e1 (diff)
downloadguix-f62a9caa367ba9cd8824699fe1ae8787a2784cd1.tar.gz
guix-f62a9caa367ba9cd8824699fe1ae8787a2784cd1.zip
gnu: python-prawcore: Update to 2.4.0.
* gnu/packages/python-web.scm (python-prawcore): Update to 2.4.0. [source]<origin>: Fetch from git to download tests. [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Skip failing tests. [native-inputs]: Add python-flit-core. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7867f2b164..bd05cb5d3f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -347,18 +347,31 @@ the command line.")
(define-public python-prawcore
(package
(name "python-prawcore")
- (version "2.3.0")
+ (version "2.4.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "prawcore" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/praw-dev/prawcore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0vgmhjddqxnz5vy70dyqvakak51fg1nk6j3xavkc83d8nzacrwfs"))))
- (build-system python-build-system)
+ (base32 "1y7gh7kk002b2h1ppkr1llb2gjfnby28zvx11j4ji0wm3r3rjh5l"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; XXX: These tests fail with an incomplete request response.
+ (list #:test-flags
+ #~'("-k" #$(string-append
+ "not test_revoke__access_token_with_refresh_set"
+ " and not test_revoke__access_token_without_refresh_set"
+ " and not test_revoke__refresh_token_with_access_set"
+ " and not test_refresh__with_scopes"
+ " and not test_request__patch"))))
(native-inputs
(list python-betamax
python-betamax-matchers
python-betamax-serializers
+ python-flit-core
python-mock
python-pytest
python-testfixtures))