aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-08-07 07:45:56 +0200
committerjgart <jgart@dismail.de>2024-08-07 22:31:59 -0500
commitf5fe501737a5ddb8f8375eaf0ff0e07f03af01b4 (patch)
treef5981b5f262cf87c848c213e855e5698107b2627 /gnu
parent2ac20ec8587e507783abf2270e13279ae24764d6 (diff)
downloadguix-f5fe501737a5ddb8f8375eaf0ff0e07f03af01b4.tar.gz
guix-f5fe501737a5ddb8f8375eaf0ff0e07f03af01b4.zip
gnu: soju: Update to 0.8.1.
Moved to Codeberg, see <https://git.sr.ht/~emersion/soju/commit/6541047>. The moderncsqlite tag needs modernc.org/sqlite, which is not packaged. * gnu/packages/irc.scm (soju): Update to 0.8.1. [source]: Update URL. [arguments]: Update #:import-path. Drop unused build flag. [native-inputs]: Use go-github-com-msteinert-pam-v2. Change-Id: I992d4e786cdabeb25fc65647c5a0b7f079df9460 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/irc.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index a298a5799c..89be2e2b66 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -1095,21 +1095,21 @@ what.")
(define-public soju
(package
(name "soju")
- (version "0.7.0")
+ (version "0.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://git.sr.ht/~emersion/soju")
+ (url "https://codeberg.org/emersion/soju")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1a0mp8f5i1ajh67y6fasmzgca3w1ccaiz19sx87rflbyi1mrhdlz"))))
+ (base32 "10qc0g78yhsg6fnnb046jr0s592isw0r0mvydy6frgnx9rxac6k6"))))
(build-system go-build-system)
(arguments
(list
#:install-source? #f
- #:import-path "git.sr.ht/~emersion/soju"
+ #:import-path "codeberg.org/emersion/soju"
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'adjust-makefile
@@ -1125,9 +1125,7 @@ what.")
(replace 'build
(lambda* (#:key import-path #:allow-other-keys)
(with-directory-excursion (string-append "src/" import-path)
- ;; To use an alternative SQLite library that does not require
- ;; CGO and build with PAM.
- (setenv "GOFLAGS" "-v -x -trimpath -tags=moderncsqlite -tags=pam")
+ (setenv "GOFLAGS" "-v -x -trimpath -tags=pam")
(setenv "SYSCONFDIR" (string-append #$output "/etc"))
(invoke "make"))))
(replace 'install
@@ -1142,7 +1140,7 @@ what.")
go-github-com-emersion-go-sasl
go-github-com-lib-pq
go-github-com-mattn-go-sqlite3
- go-github-com-msteinert-pam
+ go-github-com-msteinert-pam-v2
go-github-com-pires-go-proxyproto
go-github-com-prometheus-client-golang
go-github-com-sherclockholmes-webpush-go