aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-20 10:21:59 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:29 +0200
commitf41033ec2638e31228ceeb784cc4b210ffb1bfa3 (patch)
tree53464c600d014bc3def491374a089b03e21378c5 /gnu
parent7f2b754b3320ad97a914868ef8f95a3a5cac1ea2 (diff)
downloadguix-f41033ec2638e31228ceeb784cc4b210ffb1bfa3.tar.gz
guix-f41033ec2638e31228ceeb784cc4b210ffb1bfa3.zip
gnu: guix: Fix cross build of documentation translations.
This fixes building guix-ru.info when building (for the Hurd) guix.ru.texi:3489: @node `??????????????????????' previously defined guix.ru.texi:2535: here is the previous definition as @node make[2]: *** [Makefile:5287: doc/guix.ru.info] Error 1 and building guix-zn-CN.info when building (for the Hurd) guix.zh_CN.texi:651: @node `??????' previously defined guix.zh_CN.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5352: doc/guix.zh_CN.info] Error 1 and building guix-cookbook.ko when building (for the Hurd) guix-cookbook.ko.texi:781: @node `??????' previously defined guix-cookbook.ko.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5549: doc/guix-cookbook.ko.info] Error 1 * gnu/packages/package-management.scm (guix)[native-inputs]: Add libc-utf8-locales-for-target. Change-Id: I561b4da84b31b343e515559feb90d773b1cf440a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6120ace1bf..180e9c5aa8 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -465,7 +465,8 @@ $(prefix)/etc/openrc\n")))
;; the 'patch-shebangs' phase, which would otherwise
;; change it to 'GUILE/bin/guile'.
(delete 'patch-shebangs))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("locales" ,(libc-utf8-locales-for-target))
+ ("pkg-config" ,pkg-config)
;; Guile libraries are needed here for
;; cross-compilation.