aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-11-17 18:30:50 +0100
committerAndreas Enge <andreas@enge.fr>2013-11-18 21:12:27 +0100
commitf39298004162b94447a301d582e3f73892c99953 (patch)
treed1bc93e8b5cb0ddb326c07ebca1b0d7748079a7f /gnu
parentc42a4b76c400fd8cf30e145061637c70a2b12a02 (diff)
downloadguix-f39298004162b94447a301d582e3f73892c99953.tar.gz
guix-f39298004162b94447a301d582e3f73892c99953.zip
gnu: pspp: Add input cairo.
* gnu/packages/maths.scm (pspp): Add cairo and further necessary inputs. * gnu/packages/patches/pspp-tests.patch: New file, thanks to John Darrington <john@darrington.wattle.id.au>. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm13
-rw-r--r--gnu/packages/patches/pspp-tests.patch13
2 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9b2b052a52..2531285048 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -26,9 +26,11 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'gnu:))
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -132,12 +134,16 @@ LP/MIP solver is included in the package.")
version ".tar.gz"))
(sha256
(base32
- "0qhxsdbwxd3cn1shc13wxvx2lg32lp4z6sz24kv3jz7p5xfi8j7x"))))
+ "0qhxsdbwxd3cn1shc13wxvx2lg32lp4z6sz24kv3jz7p5xfi8j7x"))
+ (patches (list (search-patch "pspp-tests.patch")))))
(build-system gnu-build-system)
(inputs
- `(("gettext" ,gnu:gettext)
+ `(("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("gettext" ,gnu:gettext)
("gsl" ,gsl)
("libxml2" ,libxml2)
+ ("pango" ,pango)
("readline" ,readline)
("zlib" ,zlib)))
(native-inputs
@@ -145,8 +151,7 @@ LP/MIP solver is included in the package.")
("pkg-config" ,pkg-config)))
(arguments
`(#:configure-flags
- `("--without-cairo" ; FIXME: tests currently fail for lack of font
- "--without-gui"))) ; FIXME: package missing dependencies
+ `("--without-gui"))) ; FIXME: package missing dependencies
(home-page "http://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis")
(description
diff --git a/gnu/packages/patches/pspp-tests.patch b/gnu/packages/patches/pspp-tests.patch
new file mode 100644
index 0000000000..3e61b68804
--- /dev/null
+++ b/gnu/packages/patches/pspp-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/output/render-test.c b/tests/output/render-test.c
+index 5f4c1da..e9df96c 100644
+--- a/tests/output/render-test.c
++++ b/tests/output/render-test.c
+@@ -142,7 +142,7 @@ configure_drivers (int width, int length)
+ string_map_insert (&options, "left-margin", "0");
+ string_map_insert (&options, "right-margin", "0");
+ string_map_insert_nocopy (&options, xstrdup ("paper-size"),
+- xasprintf ("%dx%dpt", width * 5, length * 8));
++ xasprintf ("%dx%dpt", width * 5, length * 16));
+ driver = output_driver_create (&options);
+ if (driver == NULL)
+ exit (EXIT_FAILURE);