aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-03 10:38:37 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:51 +0200
commitf2d4c24c5a7eae57090314c81defd0ee9f16dcf9 (patch)
tree1377c2b6090e37b8425ee60bae85d3418dd0eeac /gnu
parent785cf0a4990305c7c41bd41139facba95dc7fea6 (diff)
downloadguix-f2d4c24c5a7eae57090314c81defd0ee9f16dcf9.tar.gz
guix-f2d4c24c5a7eae57090314c81defd0ee9f16dcf9.zip
gnu: Add rust-gat-lending-iterator-0.1.
* gnu/packages/crates-io.scm (rust-gat-lendign-iterator-0.1): New variable. Change-Id: If26f2297c017d96b1a56a13473c9888848c7cd75
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5c8cbbd77b..5e453b993b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29634,6 +29634,25 @@ derived from an internal hasher used in FireFox and Rustc.")
time, for nonorderable alphabets.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gat-lending-iterator-0.1
+ (package
+ (name "rust-gat-lending-iterator")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gat-lending-iterator" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1is3jhr615ip1jiiwwh727xswilxssp8b58cgahgq5k20ms13by9"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/Crazytieguy/gat-lending-iterator")
+ (synopsis "Library for iterators who's items can reference the iterator")
+ (description
+ "This package provides a library for iterators who's items can mutably
+reference the iterator.")
+ (license license:expat)))
+
(define-public rust-gat-std-0.1
(package
(name "rust-gat-std")