aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 21:34:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:45 +0200
commitf16a9bcd54080df6bf8f3f70145379849e608c82 (patch)
treed20a6ab564bcb042e6f9009b2de50dfdd0e6834c /gnu
parent90c87334a67d56a9d5d07bfc7b598013383ce2db (diff)
downloadguix-f16a9bcd54080df6bf8f3f70145379849e608c82.tar.gz
guix-f16a9bcd54080df6bf8f3f70145379849e608c82.zip
gnu: Add rust-sequoia-wot-0.12.
* gnu/packages/sequoia.scm (rust-sequoia-wot-0.12): New variable. (rust-sequoia-wot-0.11): Remove variable. (sequoia-wot): Inherit from rust-sequoia-wot-0.12. Change-Id: Iec1b577bea99538351134b9d6819a86ab9723663
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sequoia.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index ebed2979c3..eae8964502 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -813,17 +813,17 @@ Although the above appear simple to parse, RFC 2822's whitespace and comment
rules are rather complex. This crate implements the whole grammar." )
(license license:gpl3)))
-(define-public rust-sequoia-wot-0.11
+(define-public rust-sequoia-wot-0.12
(package
(name "rust-sequoia-wot")
- (version "0.11.0")
+ (version "0.12.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "sequoia-wot" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0hb17adcqz357ci3d4v57pmywy4giq8591p1vb7p83h56zdk0sfi"))))
+ (base32 "1nrx1cn58d8lkp2g0ahw2320zmil3ryxl13inpwf61v4vqi5svj8"))))
(build-system cargo-build-system)
(arguments
`(#:features '("sequoia-openpgp/crypto-nettle")
@@ -831,17 +831,15 @@ rules are rather complex. This crate implements the whole grammar." )
;; Not all files included.
"--skip=gpg_trust_roots")
#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
- ("rust-anyhow" ,rust-anyhow-1)
("rust-chrono" ,rust-chrono-0.4)
("rust-clap" ,rust-clap-4)
- ("rust-clap" ,rust-clap-4)
("rust-clap-complete" ,rust-clap-complete-4)
("rust-clap-mangen" ,rust-clap-mangen-0.2)
("rust-crossbeam" ,rust-crossbeam-0.8)
("rust-dot-writer" ,rust-dot-writer-0.1)
("rust-enumber" ,rust-enumber-0.3)
("rust-num-cpus" ,rust-num-cpus-1)
- ("rust-sequoia-cert-store" ,rust-sequoia-cert-store-0.5)
+ ("rust-sequoia-cert-store" ,rust-sequoia-cert-store-0.6)
("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1)
("rust-sequoia-policy-config" ,rust-sequoia-policy-config-0.6)
("rust-thiserror" ,rust-thiserror-1))
@@ -995,10 +993,10 @@ This Guix package is built to use the nettle cryptographic library.")
(define-public sequoia-wot
(package
- (inherit rust-sequoia-wot-0.11)
+ (inherit rust-sequoia-wot-0.12)
(name "sequoia-wot")
(arguments
- (substitute-keyword-arguments (package-arguments rust-sequoia-wot-0.11)
+ (substitute-keyword-arguments (package-arguments rust-sequoia-wot-0.12)
((#:install-source? _ #t) #f)
((#:phases phases '%standard-phases)
`(modify-phases ,phases