aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2020-02-03 23:06:09 -0600
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-04 12:30:32 +0100
commitf1452776ac65bd03454b1e715c44f7eded237ea0 (patch)
tree0c811ffd2929c499156706776a9ed523a5563f27 /gnu
parent52e7bcfd8959a1e2b66a6b313d2c82ce7779da63 (diff)
downloadguix-f1452776ac65bd03454b1e715c44f7eded237ea0.tar.gz
guix-f1452776ac65bd03454b1e715c44f7eded237ea0.zip
gnu: netsurf: Fix entity parsing.
Follow-up to commit 31afa654c58cd7aa8bd11a771fa6eabcd766d443. * gnu/packages/web.scm (netsurf)[arguments]: In 'adjust-welcome' phase, ensure html entities are parsed and find their way back to the output. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f6ae958ae3..60fd5cfd0f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
@@ -5075,12 +5075,19 @@ w3c webidl files and a binding configuration file.")
;; Leave the DOCTYPE header as is.
(display (read-line in 'concat) out)
(sxml->xml
- (let rec ((sxml (xml->sxml in)))
+ (let rec ((sxml (xml->sxml in
+ #:default-entity-handler
+ (lambda (port name)
+ (string-append "<ENTITY>"
+ (symbol->string name)
+ "</ENTITY>")))))
;; We'd like to use sxml-match here, but it can't
;; match against generic tag symbols...
(match sxml
(`(div (@ (class "links")) . ,rest)
'())
+ (`(ENTITY ,ent)
+ `(*ENTITY* ,ent))
((x ...)
(map rec x))
(x x)))
ome-keyring: Update to 3.12.0.Efraim Flashner * gnu/packages/gnome.scm (libgnome-keyring): Update to 3.12.0. 2015-12-09gnu: gmime: Update to 2.6.20.Efraim Flashner * gnu/packages/mail.scm (gmime): Update to 2.6.20. [arguments]: Use modify-phases syntax. 2015-12-08gnu: guile-sly: Use HTTPS URL.Ludovic Courtès * gnu/packages/guile.scm (guile-sly)[source]: Use 'https'. Failing to do that, we get redirected to 'https', which fails because GnuTLS is missing. 2015-12-08gnu: python-pillow: Update to 3.0.0.Andreas Enge * gnu/packages/python.scm (python-pillow, python2-pillow): Update to 3.0.0. 2015-12-08gnu: numactl: Update to 2.0.10.Andreas Enge * gnu/packages/linux.scm (numactl)[source]: Update to 2.0.10. [arguments]: Adapt phases to use the autotools machinery. [native-inputs]: Add autotools packages. 2015-12-08gnu: glade3: Update to 3.8.5.Efraim Flashner * gnu/packages/gnome.scm (glade3): Update to 3.8.5. 2015-12-08gnu: autogen: Update to 5.18.7.Efraim Flashner * gnu/packages/autogen.scm (autogen): Update to 5.18.7. 2015-12-07gnu: node: Do not use bundled dependencies.David Thompson The Node build system was previously building its own copies of OpenSSL (yikes!), libuv, and zlib. * gnu/packages/node.scm (node)[inputs]: Add openssl, libuv, and zlib. [arguments]: Add configure flags for using system libraries. Use 'modify-phases' syntax. 2015-12-07gnu: util-linux: Make description more descriptive.Leo Famulari * gnu/packages/linux.scm (util-linux)[description]: Give some more information about the package. Signed-off-by: Andreas Enge <andreas@enge.fr> 2015-12-07gnu: pcre: Update to 8.38.Mark H Weaver * gnu/packages/pcre.scm (pcre): Update to 8.38. Add source URI for main FTP site. 2015-12-07gnu: libxml2: Update to 2.9.3.Mark H Weaver * gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: Delete files. * gnu-system.am (dist_patch_DATA): Remove them. * gnu/packages/xml.scm (libxml2): Update to 2.9.3. Remove patches. 2015-12-07gnu: openssl: Update to 1.0.2e [fixes CVE-2015-{3193,3194,3195}].Mark H Weaver * gnu/packages/tls.scm (openssl): Update to 1.0.2e. [arguments]: Rename 'fix-man-dir' phase to 'patch-Makefile.org', and patch SHELL in Makefile.org. Add 'fix-broken-symlinks' phase. Return #t from 'patch-tests' phase. 2015-12-07gnu: keepassx: Update to 2.0.Efraim Flashner * gnu/packages/password-utils.scm (keepassx): Update to 2.0. [source]: Change to official release location. 2015-12-07gnu: python2-zope-security: Use python2-zope-testrunner.Efraim Flashner * gnu/packages/python.scm (python2-zope-security): Do it. 2015-12-07gnu: help2man: Update to 1.47.3.Efraim Flashner * gnu/packages/man.scm (help2man): Update to 1.47.3. 2015-12-07gnu: libmicrohttpd: Update to 0.9.47.Efraim Flashner * gnu/packages/gnunet.scm (libmicrohttpd): Update to 0.9.47. 2015-12-06gnu: mp3info: Update URL.Alex Vong * gnu/packages/mp3.scm (mp3info): Update source URL. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2015-12-06gnu: Add myrepos.Kyle Meyer * gnu/packages/version-control.scm (myrepos): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2015-12-06gnu: Add python-docopt.Kyle Meyer * gnu/packages/python.scm (python-docopt, python2-docopt): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2015-12-06gnu: gajim: Update to 0.16.4.Efraim Flashner * gnu/packages/messaging.scm (gajim): Update to 0.16.4. 2015-12-06gnu: pinentry: Update to 0.9.6.Efraim Flashner * gnu/packages/gnupg.scm (pinentry): Update to 0.9.6. [inputs]: Add libsecret. 2015-12-06gnu: gpgme: Update to 1.6.0.Efraim Flashner * gnu/packages/gnupg.scm (gpgme): Update to 1.6.0. 2015-12-06gnu: gnupg: Update to 2.1.10.Efraim Flashner * gnu/packages/gnupg.scm (gnupg): Update to 2.1.10. [inputs]: Add adns. 2015-12-06gnu: gnupg-2.0: Update to 2.0.29.Efraim Flashner * gnu/packages/gnupg.scm (gnupg-2.0): Update to 2.0.29. [inputs]: Add adns. 2015-12-06gnu: libassuan: Update to 2.4.2.Efraim Flashner * gnu/packages/gnupg.scm (libassuan): Update to 2.4.2. 2015-12-06gnu: Move pkg-config to native inputs.Mathieu Lirzin * gnu/packages/xiph.scm (ao)[native-inputs]: Move pkg-config from inputs. * gnu/packages/xorg.scm (xf86-video-geode)[native-inputs]: Likewise. 2015-12-06gnu: nano: Update to 2.5.0.Efraim Flashner * gnu/packages/nano.scm (nano): Update to 2.5.0. 2015-12-06gnu: gdb: Update to 7.10.1.Efraim Flashner * gnu/packages/gdb.scm (gdb): Update to 7.10.1. 2015-12-06gnu: manaplus: Update to 1.5.12.5.Alex Kost * gnu/packages/games.scm (manaplus): Update to 1.5.12.5. 2015-12-05gnu: pius: Update to 2.2.1.Ludovic Courtès * gnu/packages/gnupg.scm (pius): Update to 2.2.1. Change URL to github.com. [arguments]: Update pattern for 'gpg' command. 2015-12-05gnu: Add letsencrypt.David Thompson * gnu/packages/tls.scm (letsencrypt): New variable. 2015-12-05gnu: Add acme.Leo Famulari * gnu/packages/tls.scm (acme): New variable. 2015-12-05gnu: Add python2-parsedatetime.Leo Famulari * gnu/packages/python.scm (python2-parsedatetime): New variable. 2015-12-05gnu: python-parsedatetime: Update to 1.5.Leo Famulari * gnu/packages/python.scm (python-parsedatetime): Update to 1.5. [arguments]: Enable tests. 2015-12-05gnu: Add python-ndg-httpsclient.Leo Famulari * gnu/packages/python.scm (python-ndg-httpsclient, python2-ndg-httpsclient): New variables. 2015-12-05gnu: Add python-configargparse.Leo Famulari * gnu/packages/python.scm (python-configargparse, python2-configargparse): New variables.