aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-06 08:55:46 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-08 15:28:43 +0800
commitf1263f41ed742d89b354241a04d19c0840b86bc4 (patch)
tree5a2be02070214b6a8031fa4528a9b25382eeea2f /gnu
parent7a80df355994f3c9671d4244f80c9801f06d9833 (diff)
downloadguix-f1263f41ed742d89b354241a04d19c0840b86bc4.tar.gz
guix-f1263f41ed742d89b354241a04d19c0840b86bc4.zip
gnu: Add grimblast.
* gnu/packages/wm.scm (grimblast): New variable. Change-Id: I38d8e0ff92e8724cec64d37d036ff307c96a2cc0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0e8186e674..4be0ec5aed 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3767,6 +3767,66 @@ Type=Application~%"
used for multimedia keys.")
(license license:gpl3+)))
+(define-public grimblast
+ (let ((commit "9d67858b437d4a1299be496d371b66fc0d3e01f6")
+ (revision "1"))
+ (package
+ (name "grimblast")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/contrib")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v0v5j7ingx80b5zpyz8ilfhz0kh9dcssnx6iwwl45zzgp915cpv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;No tests.
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "grimblast")))
+ (add-after 'chdir 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "grimblast"
+ (((string-append "\\<(" (string-join
+ '("date"
+ "grim"
+ "slurp"
+ "hyprctl"
+ "hyprpicker"
+ "wl-copy"
+ "jq"
+ "notify-send")
+ "|")
+ ")\\>")
+ cmd)
+ (search-input-file
+ inputs (string-append "bin/" cmd)))))))))
+ (native-inputs (list scdoc))
+ (inputs
+ (list coreutils-minimal
+ grim
+ jq
+ libnotify
+ slurp
+ hyprland
+ hyprpicker
+ wl-clipboard))
+ (home-page "https://github.com/hyprwm/contrib")
+ (synopsis "Screenshot utility for Hyprland")
+ (description
+ "This package provides a Hyprland version of @code{grimshot} for
+screenshoting.")
+ (license license:expat))))
+
(define-public grimshot
(package
(name "grimshot")