aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 08:31:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:32 +0000
commitf0ef42b3fa090688e5083d4daafe800ad9ff35a8 (patch)
tree54a0677b641942f6fd12c4d5579069e4421146e9 /gnu
parent4a28c902e0939835ef98aa96012b26f02bf084b0 (diff)
downloadguix-f0ef42b3fa090688e5083d4daafe800ad9ff35a8.tar.gz
guix-f0ef42b3fa090688e5083d4daafe800ad9ff35a8.zip
gnu: Add python-pytest-asyncio-0.23.
* gnu/packages/check.scm (python-pytest-asyncio-0.23): New variable. Change-Id: I4de42bee146ac1e1a10de7a3b605734c2386465f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6e4fc694e0..468f3f53e6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2526,6 +2526,17 @@ testing tools. @code{pytest-asyncio} provides useful fixtures and markers
to make testing async code easier.")
(license license:asl2.0)))
+(define-public python-pytest-asyncio-0.23
+ (package
+ (inherit python-pytest-asyncio)
+ (version "0.23.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_asyncio" version))
+ (sha256
+ (base32 "1lz4h8y6m6hxnsl7kqh0rjxqp5q2wc2m5gd88371rikd7ari16vm"))))))
+
(define-public python-cov-core
(package
(name "python-cov-core")