aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authordan <i@dan.games>2022-11-19 23:02:39 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:10:54 -0400
commitf0895be9038fee4a4c162f72cddf8ff0c829dcf8 (patch)
treee97a521d4c884d358bb488162e6c38a13d1b6b02 /gnu
parent2bbfd7e4aedc4361f57bfb17a0533f6e839e2818 (diff)
downloadguix-f0895be9038fee4a4c162f72cddf8ff0c829dcf8.tar.gz
guix-f0895be9038fee4a4c162f72cddf8ff0c829dcf8.zip
gnu: spirv-tools: Replace version with %vulkan-sdk-version.
* gnu/packages/vulkan.scm (spirv-tools)[version]: Replace with %vulkan-sdk-version. The commit of tag '2022.4' and 'sdk-1.3.231.1' are the same. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vulkan.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index edf7fae73c..0ce612c1ea 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -79,13 +79,13 @@ and for the GLSL.std.450 extended instruction set.
(define-public spirv-tools
(package
(name "spirv-tools")
- (version "2022.4")
+ (version %vulkan-sdk-version)
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/KhronosGroup/SPIRV-Tools")
- (commit (string-append "v" version))))
+ (commit version)))
(sha256
(base32 "03d489ind2az7w7q1slj3mdc04372r3qqbnd7m9akxbg7yix1a5j"))
(file-name (git-file-name name version))))