aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-07-11 00:57:45 -0700
committer宋文武 <iyzsong@member.fsf.org>2024-08-10 18:22:47 +0800
commitf086d83cb6315ed85d6f891ccf87516fb18860ce (patch)
tree04f615369e761272927c272a5fa08eb46450bfc1 /gnu
parentbd43c75746553c5af05b00779bf0e12575029d76 (diff)
downloadguix-f086d83cb6315ed85d6f891ccf87516fb18860ce.tar.gz
guix-f086d83cb6315ed85d6f891ccf87516fb18860ce.zip
gnu: caja-extensions: update to 1.28.0.
* gnu/packages/mate.scm (caja-extensions): Update to 1.28.0 [arguments]<#:configure-flags>: Disable AV support as needed gstreamer components are Rust packages not in Guix at this time. Change-Id: If48fcc79618654fd29ed6222517509224fa78e37 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mate.scm65
1 files changed, 37 insertions, 28 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index b1b75002ea..c3d803e696 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -846,47 +847,55 @@ icons on the MATE desktop. It works on local and remote file systems.")
(define-public caja-extensions
(package
(name "caja-extensions")
- (version "1.26.1")
+ (version "1.28.0")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://mate/" (version-major+minor version) "/"
- "caja-extensions-" version ".tar.xz"))
+ (uri (string-append "mirror://mate/"
+ (version-major+minor version)
+ "/"
+ "caja-extensions-"
+ version
+ ".tar.xz"))
(sha256
- (base32 "086mw7650n8blnr2wkg9xdb6lhwqamcbkk5575i2s90hzbiik72q"))))
+ (base32 "0x9ikq8biaq08wzj0qqpmy8k5w7axqimigfgf7i5z0s00xg6r66j"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags (list "--enable-sendto"
;; TODO: package "gupnp" to enable 'upnp', package
;; "gksu" to enable 'gksu'.
- (string-append "--with-sendto-plugins=removable-devices,"
- "caja-burn,emailclient,pidgin,gajim")
+ (string-append
+ "--with-sendto-plugins=removable-devices,"
+ "caja-burn,emailclient,pidgin,gajim")
"--enable-image-converter"
- "--enable-open-terminal" "--enable-share"
- "--enable-wallpaper" "--enable-xattr-tags"
+ "--enable-open-terminal"
+ "--enable-share"
+ "--enable-wallpaper"
+ "--enable-xattr-tags"
+ "--enable-av=yes"
+
(string-append "--with-cajadir="
(assoc-ref %outputs "out")
"/lib/caja/extensions-2.0/"))))
- (native-inputs
- `(("intltool" ,intltool)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
- ("libxml2" ,libxml2)
- ("pkg-config" ,pkg-config)))
- (inputs
- (list attr
- brasero
- caja
- dbus
- dbus-glib
- gajim ;runtime only?
- gtk+
- graphicsmagick
- mate-desktop
- pidgin ;runtime only?
- startup-notification))
+ (native-inputs `(("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)))
+ (inputs (list attr
+ brasero
+ caja
+ dbus
+ dbus-glib
+ gajim ;runtime only?
+ gst-plugins-base
+ gtk+
+ graphicsmagick
+ mate-desktop
+ pidgin ;runtime only?
+ startup-notification))
(home-page "https://mate-desktop.org/")
(synopsis "Extensions for the File manager Caja")
(description