aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-08 21:20:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:30 -0400
commitf059d35323a176d71dfe290a67317dcbec61f19c (patch)
tree33363b87bf22d2e6e38d3d15afd7960f0aa1f3fc /gnu
parent53cbf59923c8aa13c154d491f472523bed05bf0d (diff)
downloadguix-f059d35323a176d71dfe290a67317dcbec61f19c.tar.gz
guix-f059d35323a176d71dfe290a67317dcbec61f19c.zip
gnu: Add ruby-bake-test-external.
* gnu/packages/ruby.scm (ruby-bake-test-external): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 304fa815c8..fb44385dc3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3814,6 +3814,28 @@ well as @samp{rake}.")
(home-page "https://github.com/ioquatix/bake-test")
(license license:expat)))
+(define-public ruby-bake-test-external
+ (package
+ (name "ruby-bake-test-external")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "bake-test-external" version))
+ (sha256
+ (base32
+ "0749xc7jkz1c5gsq1giwhrqy6s6xqm48bdvs414372881wki2jmh"))))
+ (build-system ruby-build-system)
+ ;; The test suite relies on git and network access to clone external
+ ;; repositories.
+ (arguments (list #:tests? #f))
+ (propagated-inputs (list ruby-bake))
+ (synopsis "Continuous integration extension for Bake")
+ (description "Bake Test External adds a @samp{test:external} action to the
+@command{bake} command to run the test suites of dependent projects to check
+for breakage.")
+ (home-page "https://github.com/ioquatix/bake-test-external")
+ (license license:expat)))
+
(define-public ruby-connection-pool
(package
(name "ruby-connection-pool")