aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:27:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commitf0514b9cac5fe10c75d31f6c90fa3c8160354fd5 (patch)
tree6187003816c55a0f7abcc39fdeaaf9f6cbec475a /gnu
parent9f5cc3f8f4c2b39c3092fef11f1bd2386fe8a2c4 (diff)
downloadguix-f0514b9cac5fe10c75d31f6c90fa3c8160354fd5.tar.gz
guix-f0514b9cac5fe10c75d31f6c90fa3c8160354fd5.zip
gnu: Add ghc-crypton-x509.
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509): New variable. Change-Id: I0bea5088c2fd23b77f22a2017303bac849c45c29
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-crypto.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index f119fe06ba..bd8007e496 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -648,6 +648,37 @@ abstraction for CPRNGs.")
@end itemize")
(license license:bsd-3)))
+(define-public ghc-crypton-x509
+ (package
+ (name "ghc-crypton-x509")
+ (version "1.7.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "crypton-x509" version))
+ (sha256
+ (base32 "1zyaz0krf08g36g30zr5wn8f2x51l4dj2zcjnhpiw9h05p54mdzb"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "crypton-x509")))
+ (inputs (list ghc-memory
+ ghc-hourglass
+ ghc-pem
+ ghc-asn1-types
+ ghc-asn1-encoding
+ ghc-asn1-parse
+ ghc-crypton))
+ (native-inputs (list ghc-tasty ghc-tasty-quickcheck ghc-x509))
+ (arguments
+ `(#:cabal-revision ("1"
+ "10a2x47znhbayyfr6fqgq27623akpycyjbfxz4hnavavf1x6ary5")
+ ;; build phase fails when tests are activated.
+ ;; See https://github.com/kazu-yamamoto/crypton-certificate/pull/7
+ #:tests? #f))
+ (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+ (synopsis "X509 reader and writer")
+ (description "This package provides generic X509 support for Haskell.")
+ (license license:bsd-3)))
+
(define-public ghc-cprng-aes
(package
(name "ghc-cprng-aes")