aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-12 20:26:27 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 14:17:33 +0100
commiteefb9dcbe23e0408546a81faa1c0d0116a948516 (patch)
treed8af00590f380b618d47b296a7711f017e868031 /gnu
parente2d9756c8032172b47a312d858b5530e1efb66ac (diff)
downloadguix-eefb9dcbe23e0408546a81faa1c0d0116a948516.tar.gz
guix-eefb9dcbe23e0408546a81faa1c0d0116a948516.zip
gnu: Add go-github-com-containerd-fifo.
* gnu/packages/golang-xyz.scm (go-github-com-containerd-fifo): New variable. Change-Id: I782f792560bdbe59d31fac7762e07b378a9c29fb Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d5eb97b8dc..39f838196d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1432,6 +1432,33 @@ levels that works by wrapping the standard @code{log} library.")
"Readline is a pure Go implementation of a GNU-Readline like library.")
(license license:expat)))
+(define-public go-github-com-containerd-fifo
+ (package
+ (name "go-github-com-containerd-fifo")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/fifo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ddb1spairbsjkvxqysa7pzb5za07dvv1aay3mqr160gh2za3kd4"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/containerd/fifo"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/containerd/fifo")
+ (synopsis "FIFO package for Golang")
+ (description
+ "This package implements a functionality of handling FIFOs in a sane
+way.")
+ (license license:asl2.0)))
+
(define-public go-github-com-coocood-freecache
(package
(name "go-github-com-coocood-freecache")