aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-10-24 13:44:20 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-26 10:10:12 +0800
commitee758cc436500f566d105ca7e1d15d480625bd65 (patch)
tree94e34453cc3354ff7bdc080a9189ba1500e423de /gnu
parent7bf7688a0eb49043abd70395c792b10e2e374ca5 (diff)
downloadguix-ee758cc436500f566d105ca7e1d15d480625bd65.tar.gz
guix-ee758cc436500f566d105ca7e1d15d480625bd65.zip
gnu: Add calligra.
* gnu/packages/kde-office.scm: New file. * gnu/local.mk: Register it. Change-Id: Id114f80ba804ee2d0129b5a17722be2eda54250b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kde-office.scm144
2 files changed, 145 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ecfc12a87c..6bd7c75090 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -399,6 +399,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kde-games.scm \
%D%/packages/kde-internet.scm \
%D%/packages/kde-multimedia.scm \
+ %D%/packages/kde-office.scm \
%D%/packages/kde-pim.scm \
%D%/packages/kde-plasma.scm \
%D%/packages/kde-systemtools.scm \
diff --git a/gnu/packages/kde-office.scm b/gnu/packages/kde-office.scm
new file mode 100644
index 0000000000..c4e3c757b5
--- /dev/null
+++ b/gnu/packages/kde-office.scm
@@ -0,0 +1,144 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Sughosha <sughosha@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-office)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system qt)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages graphics)
+ #:use-module (gnu packages kde)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages libreoffice)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages wm)
+ #:use-module (gnu packages xdisorg))
+
+(define-public calligra
+ (package
+ (name "calligra")
+ (version "4.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/calligra/"
+ "calligra-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0pyri2ypzva4b4rnl2p3xp0ph5xcn181msj86l5xq6sg7zkza0fl"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ ;; XXX: 26/164 tests fail.
+ #:configure-flags
+ #~(list "-DBUILD_TESTING=OFF")
+ #:tests? #f))
+ (native-inputs
+ (list extra-cmake-modules kdoctools perl pkg-config))
+ (inputs
+ (list boost
+ eigen
+ fontconfig
+ freetype
+ gsl
+ imath
+ karchive
+ kcmutils
+ kcompletion
+ kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ kdiagram
+ kguiaddons
+ ki18n
+ kiconthemes
+ kio
+ kitemviews
+ kjobwidgets
+ knotifications
+ knotifyconfig
+ ktextwidgets
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ lcms
+ libdisplay-info
+ libetonyek
+ libgit2
+ libodfgen
+ librevenge
+ libvisio
+ libwpd
+ libwpg
+ libwps
+ libxkbcommon
+ okular
+ openexr
+ openssl
+ phonon
+ poppler-qt6
+ pstoedit
+ qca-qt6
+ qtkeychain-qt6
+ qtsvg
+ qtwebengine
+ shared-mime-info
+ sonnet
+ threadweaver
+ zlib))
+ (home-page "https://calligra.org/")
+ (synopsis "Office and graphic art suite")
+ (description
+ "Calligra Suite is a collection of office applications linked together by
+a common base.
+
+The applications currently included in Calligra Suite are:
+
+Office productivity:
+@itemize
+@item Words: Word processor
+@item Sheets: Spreadsheet calculator
+@item Stage: Presentation program
+@end itemize
+
+Graphics:
+@itemize
+@item Karbon: Vector graphics
+@end itemize
+
+Advanced plugins:
+@itemize
+@item Chart: Graphic data visualization
+@item KFormula: Mathematical formulas
+@end itemize")
+ (license (list license:lgpl2.0+ license:gpl2+))))