aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commitee64bcfb796ef36db4b63f79540627fb25f3320a (patch)
tree360eefab8c1bfdd0c872a10e83221976c4afe44d /gnu
parent6078dd42d2c5ff3b4298a6e4b2192d7eb216c8ba (diff)
downloadguix-ee64bcfb796ef36db4b63f79540627fb25f3320a.tar.gz
guix-ee64bcfb796ef36db4b63f79540627fb25f3320a.zip
gnu: armagetronad: Update to 0.2.9.2.3.
* gnu/packages/games.scm (armagetronad): Update to 0.2.9.2.3. [arguments]: Add a new 'omit-broken-symlinks phase. Change-Id: I2283e27facdccfb28034434253a2a3b079ceb4c4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fe3337c5f8..ea3f0b7b8b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -488,19 +488,28 @@ Doom clone shooter game.")
(define-public armagetronad
(package
(name "armagetronad")
- (version "0.2.9.1.1")
+ (version "0.2.9.2.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/armagetronad/stable/"
version "/armagetronad-" version ".tbz"))
(sha256
(base32
- "0cpxvzbssyf45fmanp1d6l992wln8zkjx4z2flgx27fg1rqdw5zn"))))
+ "0a6rlp2lj5bp7pg1yf8brjyb3mw7nqp3amj19wvz3xni21bbc31k"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
- #~(list "--disable-games" ;don't nest everything in ‘games/’
- "--disable-uninstall"))) ;pointless (and broken) in Guix
+ #~(list "--disable-games" ;don't nest everything in ‘games/’
+ "--disable-uninstall") ;pointless (and broken) in Guix
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'omit-broken-symlinks
+ ;; v0.2.9.2.0 added relative_path() which I think broke
+ ;; install_link(). It now creates a broken armagetronad-master
+ ;; symlink that causes the 'validate-runpath phase to fail.
+ (lambda _
+ (substitute* "batch/sysinstall.in"
+ (("^install_link .*BINDIR.*") "")))))))
(native-inputs (list pkg-config))
(inputs (list libxml2
(sdl-union (list sdl sdl-image sdl-mixer))