aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:23:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:06 +0200
commitecf940ea3eb47ebd1a66b0b9a8149e16f4e8b5b3 (patch)
treed06e8247dec63dc2ffe07a4c6951e824a9188976 /gnu
parent4f37ade08ac069bb79722e41bdb6c2fb8a4d6061 (diff)
downloadguix-ecf940ea3eb47ebd1a66b0b9a8149e16f4e8b5b3.tar.gz
guix-ecf940ea3eb47ebd1a66b0b9a8149e16f4e8b5b3.zip
gnu: emacs-gntp: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-gntp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2e43411b62..c48c21d284 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6001,14 +6001,13 @@ you to deal with multiple log levels.")
(version "0.1")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/tekai/gntp.el/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tekai/gntp.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "16c1dfkia9yhl206bdhjr3b8kfvqcqr38jl5lq8qsyrrzsnmghny"))))
+ (base32 "1nvyjjjydrimpxy4cpg90si7sr8lmldbhlcm2mx8npklp9pn5y3a"))))
(build-system emacs-build-system)
(home-page "https://github.com/tekai/gntp.el")
(synopsis "Growl Notification Protocol for Emacs")