aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:51:28 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commitec77a714c5642ac35366fd6c31aee29847b77cb7 (patch)
tree77d01722adbc770e974b52a665d6bb869659c056 /gnu
parentd0662af9556d19dedfc3cc9595c0169f0ed967f4 (diff)
downloadguix-ec77a714c5642ac35366fd6c31aee29847b77cb7.tar.gz
guix-ec77a714c5642ac35366fd6c31aee29847b77cb7.zip
gnu: Add parent.
* gnu/packages/perl.scm (perl-parent): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8d9e9f6a2c..f87606eadf 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1128,6 +1128,25 @@ is particularly useful for debugging.")
checking parameters easier.")
(license (package-license perl))))
+(define-public perl-parent
+ (package
+ (name "perl-parent")
+ (version "0.228")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CO/CORION/"
+ "parent-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w0i02y4z8465z050kml57mvhv7c5gl8w8ivplhr3cms0zbaq87b"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/parent")
+ (synopsis "Establish an ISA relationship with base classes at compile time")
+ (description "Allows you to both load one or more modules, while setting
+up inheritance from those modules at the same time.")
+ (license (package-license perl))))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")