aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-09-12 08:31:36 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-24 14:49:09 +0200
commitebe9d660a55629f2506db124b0e016885fc61e5c (patch)
tree9d6e9b7345a2b1ae214d4117428a0748501426af /gnu
parenta13f5ead0265cf0fe11e60150547c09dfc8c45b0 (diff)
downloadguix-ebe9d660a55629f2506db124b0e016885fc61e5c.tar.gz
guix-ebe9d660a55629f2506db124b0e016885fc61e5c.zip
gnu: Add compression module.
Move the compression record to a dedicated module so that it can be used outside (guix scripts pack) module. * guix/scripts/pack.scm (<compressor>, %compressors, lookup-compressor): Move it to ... * gnu/compression.scm: ... this new file. * gnu/ci.scm: Adapt it. * local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/ci.scm3
-rw-r--r--gnu/compression.scm69
-rw-r--r--gnu/local.mk1
3 files changed, 72 insertions, 1 deletions
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 2c51ea7387..19a48bdbf1 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -39,9 +39,10 @@
#:select (gpl3+ license? license-name))
#:use-module ((guix utils) #:select (%current-system))
#:use-module ((guix scripts pack)
- #:select (lookup-compressor self-contained-tarball))
+ #:select (self-contained-tarball))
#:use-module (gnu bootloader)
#:use-module (gnu bootloader u-boot)
+ #:use-module (gnu compression)
#:use-module (gnu image)
#:use-module (gnu packages)
#:use-module (gnu packages gcc)
diff --git a/gnu/compression.scm b/gnu/compression.scm
new file mode 100644
index 0000000000..0418e80a15
--- /dev/null
+++ b/gnu/compression.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu compression)
+ #:use-module (guix gexp)
+ #:use-module (guix ui)
+ #:use-module ((gnu packages compression) #:hide (zip))
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-9)
+ #:use-module (ice-9 match)
+ #:export (compressor
+ compressor?
+ compressor-name
+ compressor-extension
+ compressor-command
+ %compressors
+ lookup-compressor))
+
+;; Type of a compression tool.
+(define-record-type <compressor>
+ (compressor name extension command)
+ compressor?
+ (name compressor-name) ;string (e.g., "gzip")
+ (extension compressor-extension) ;string (e.g., ".lz")
+ (command compressor-command)) ;gexp (e.g., #~(list "/gnu/store/…/gzip"
+ ; "-9n" ))
+
+(define %compressors
+ ;; Available compression tools.
+ (list (compressor "gzip" ".gz"
+ #~(list #+(file-append gzip "/bin/gzip") "-9n"))
+ (compressor "lzip" ".lz"
+ #~(list #+(file-append lzip "/bin/lzip") "-9"))
+ (compressor "xz" ".xz"
+ #~(append (list #+(file-append xz "/bin/xz")
+ "-e")
+ (%xz-parallel-args)))
+ (compressor "bzip2" ".bz2"
+ #~(list #+(file-append bzip2 "/bin/bzip2") "-9"))
+ (compressor "zstd" ".zst"
+ ;; The default level 3 compresses better than gzip in a
+ ;; fraction of the time, while the highest level 19
+ ;; (de)compresses more slowly and worse than xz.
+ #~(list #+(file-append zstd "/bin/zstd") "-3"))
+ (compressor "none" "" #f)))
+
+(define (lookup-compressor name)
+ "Return the compressor object called NAME. Error out if it could not be
+found."
+ (or (find (match-lambda
+ (($ <compressor> name*)
+ (string=? name* name)))
+ %compressors)
+ (leave (G_ "~a: compressor not found~%") name)))
diff --git a/gnu/local.mk b/gnu/local.mk
index 140845a7c6..4774be2688 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -81,6 +81,7 @@ GNU_SYSTEM_MODULES = \
%D%/bootloader/u-boot.scm \
%D%/bootloader/depthcharge.scm \
%D%/ci.scm \
+ %D%/compression.scm \
%D%/home.scm \
%D%/home/services.scm \
%D%/home/services/desktop.scm \