aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 09:06:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:46 -0400
commitebd9041614b201c2cb1424d5391365d5aea071d8 (patch)
treec2bf6fa7df7603771c3bb3ab1654b0004679d413 /gnu
parent04ed75cc9de4a8302ad1d168fb1b114a81a27a86 (diff)
downloadguix-ebd9041614b201c2cb1424d5391365d5aea071d8.tar.gz
guix-ebd9041614b201c2cb1424d5391365d5aea071d8.zip
gnu: gnome-klotski: Update to 3.38.2.
* gnu/packages/gnome.scm (gnome-klotski): Update to 3.38.2. [phases]: Delete trailing #t. [native-inputs]: Remove labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 66d84e27e2..f81f6b2bbc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6341,7 +6341,7 @@ GNOME Games, but it may be used by others.")
(define-public gnome-klotski
(package
(name "gnome-klotski")
- (version "3.34.0")
+ (version "3.38.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6349,7 +6349,7 @@ GNOME Games, but it may be used by others.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0sbx0bzy32lh2c9jp8v7gz788wn9y1la8mr5a7gf7370szsl4d4f"))))
+ "1qm01hdd5yp8chig62bj10912vclbdvywwczs84sfg4zci2phqwi"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -6359,16 +6359,15 @@ GNOME Games, but it may be used by others.")
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "build-aux/meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))
- #t)))))
+ (("gtk-update-icon-cache") (which "true"))))))))
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("xmllint" ,libxml2)))
+ (list desktop-file-utils
+ `(,glib "bin") ; for glib-compile-resources
+ intltool
+ itstool
+ pkg-config
+ vala
+ libxml2))
(inputs
(list gtk+
libgnome-games-support-1