aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-07 19:32:11 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-09 04:54:20 +0400
commiteb6a46fcb7e96b0a97dede35a6a7d54b3f63f34d (patch)
treeb4e1ec474df8e2424ae62d92057dcbd07e3610f4 /gnu
parent13b15c5e8934208b6d2f94151f1a157a5a24d622 (diff)
downloadguix-eb6a46fcb7e96b0a97dede35a6a7d54b3f63f34d.tar.gz
guix-eb6a46fcb7e96b0a97dede35a6a7d54b3f63f34d.zip
gnu: erlang-jose: Relax build options.
* gnu/packages/erlang-xyz.scm (erlang-jose): Relax build options. Change-Id: I0e90cb54558260aea07bc33a11a2ab56261a20bf Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/erlang-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 5661bf52dd..6f1c033aec 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -59,6 +59,18 @@
(sha256
(base32 "0576jdjygby37qmzrs8cm5l6n622b0mi3z28j6r4s5xsz1px6v0d"))))
(build-system rebar-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Do not treat warnings as errors, for more info see:
+ ;; https://github.com/potatosalad/erlang-jose/issues/168
+ (add-after 'unpack 'relax-build-options
+ (lambda _
+ (substitute* "rebar.config"
+ (("debug_info,") "debug_info"))
+ (substitute* "rebar.config"
+ (("warnings_as_errors") "")))))))
(synopsis
"JSON Object Signing and Encryption for Erlang and Elixir")
(description