aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-11 17:58:34 +0000
committerMathieu Othacehe <othacehe@gnu.org>2023-10-25 11:59:59 +0200
commiteb194aba18f7f81974d6d8999adbfda88f18cfce (patch)
tree0423c67a1ad43f1d2f0faf4db1819e43cd2b3175 /gnu
parent50fa8bd0a31a992fe19b39f06c0662c58418153a (diff)
downloadguix-eb194aba18f7f81974d6d8999adbfda88f18cfce.tar.gz
guix-eb194aba18f7f81974d6d8999adbfda88f18cfce.zip
gnu: python-versioneer: Update to 0.29.
* gnu/packages/python-xyz.scm (python-versioneer): Update to 0.29. [build-system]: Switch to pyproject-build-system. [arguments, native-inputs, propagated-inputs]: New fields. [license]: Set to Unlicense. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 30 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3afef5d337..6b991c448b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29901,26 +29901,48 @@ applications with variable CPU loads).")
(define-public python-versioneer
(package
(name "python-versioneer")
- (version "0.21")
+ (version "0.29")
(source
(origin
(method url-fetch)
(uri (pypi-uri "versioneer" version))
(sha256
(base32
- "084fglxafbzvf1vbkzfajvs9qwnvjwwn8pxql9nrlpyipv5xpwk4"))
+ "0cap4cjckxp9mlkprqayfs77k3pn5iwpr2riacdxc4bjhnwq7cjs"))
(patches (search-patches "python-versioneer-guix-support.patch"))))
- (build-system python-build-system)
- (home-page
- "https://github.com/python-versioneer/python-versioneer")
- (synopsis
- "Version-string management for VCS-controlled trees")
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Taken from tox.ini.
+ (invoke "python" "setup.py" "make_versioneer")
+ (invoke "python" "-m" "unittest" "discover" "test")
+ (invoke "python" "test/git/test_git.py" "-v")
+ ;; Some invocation tests require the network.
+ ;;(invoke "python" "test/git/test_invocations.py" "-v")
+ (invoke "python" "setup.py" "make_long_version_py_git")
+ (invoke "pyflakes" "setup.py" "versioneer.py" "git_version.py")
+ (invoke "python" "test/run_pyflakes_src.py")
+ (invoke "pyflakes" "test")
+ (invoke "flake8" "git_version.py" "versioneer.py")
+ (invoke "pycodestyle" "--max-line-length=88"
+ "git_version.py" "versioneer.py")))))))
+ (native-inputs
+ (list git python-flake8 python-pycodestyle python-pyflakes))
+ (propagated-inputs
+ (list python-tomli))
+ (home-page "https://github.com/python-versioneer/python-versioneer")
+ (synopsis "Version-string management for VCS-controlled trees")
(description
"@code{versioneer} is a tool for managing a recorded version number in
distutils-based python projects. The goal is to remove the tedious and
error-prone \"update the embedded version string\" step from your release
process.")
- (license license:public-domain)))
+ (license license:unlicense)))
(define-public python-gamera
(package