aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-01 16:01:49 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-01 16:01:49 +0200
commitea7f3349ba59cb56087d3ca3ab4c101f372d0eac (patch)
tree9e0d0cac0020fe95dbfd3f3e61734510c9f60904 /gnu
parentbf4af30bb2bce9dd5baf91f313ea35c55893eb10 (diff)
downloadguix-ea7f3349ba59cb56087d3ca3ab4c101f372d0eac.tar.gz
guix-ea7f3349ba59cb56087d3ca3ab4c101f372d0eac.zip
gnu: ganv: Set the RUNPATH of binaries to $libdir.
* gnu/packages/gtk.scm (ganv)[arguments]: Add 'set-ldflags' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0f7ba863e8..8a5a3099bf 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -230,13 +230,21 @@ functions which were removed.")
(source (origin
(method url-fetch)
(uri (string-append "http://download.drobilla.net/ganv-"
- version
- ".tar.bz2"))
+ version ".tar.bz2"))
(sha256
(base32
"0g7s5mp14qgbfjdql0k1s8464r21g47ssn5dws6jazsnw6njhl0l"))))
(build-system waf-build-system)
- (arguments `(#:tests? #f)) ; no check target
+ (arguments
+ `(#:phases (alist-cons-before
+ 'configure 'set-ldflags
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Allow 'bin/ganv_bench' to find libganv-1.so.
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib")))
+ %standard-phases)
+ #:tests? #f)) ; no check target
(inputs
`(("gtk" ,gtk+-2)
("gtkmm" ,gtkmm-2)))
a href='/guix/commit/gnu/machine?id=70ffa8af1e93ab8a92c4622745e9cb4a2782f3c8'>machine: ssh: Do not import the host (guix config)....Ludovic Courtès 2020-11-01system: Add store-directory-prefix to boot-parameters....Miguel Ángel Arruga Vivas 2020-10-18system: Provide locale information to the bootloader....Miguel Ángel Arruga Vivas 2020-09-07linux-boot: Handle nfs-root device strings....Stefan 2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe 2020-08-25linux-libre: Support module compression....Mathieu Othacehe 2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès 2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès 2020-06-28Add more missing (ice-9 format) imports....Marius Bakke 2020-06-18machine: ssh: Fix guix deploy hang when using non-DCE UUIDs....Maxim Cournoyer 2020-03-23machine: ssh: Better report missing initrd modules....Ludovic Courtès 2020-03-23machine: ssh: Make sanity checks in a single round trip....Ludovic Courtès 2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice 2019-12-08machine: Remove unnecessary record self-referencing bindings....Ludovic Courtès 2019-12-07machine: ssh: Deprecate missing 'host-key' field....Ludovic Courtès 2019-12-04machine: ssh: <machine-ssh-configuration> can include the host key....Ludovic Courtès 2019-10-22machine: digital-ocean: Rename 'enable-ipv6' to 'enable-ipv6?'....Ludovic Courtès 2019-10-22machine: Implement 'digital-ocean-environment-type'....Jakob L. Kreuze 2019-08-17machine: ssh: Fix sanity checks....宋文武 2019-08-16machine: Use 'become-command'....Jakob L. Kreuze 2019-08-15machine: Automatically authorize the coordinator's signing key....Jakob L. Kreuze 2019-08-15machine: Implement 'roll-back-machine'....Jakob L. Kreuze 2019-08-15machine: Allow non-root users to deploy....Jakob L. Kreuze 2019-08-14remote: Build derivations appropriate for the remote's...Jakob L. Kreuze 2019-08-07machine: Add 'build-locally?' field for managed hosts....Jakob L. Kreuze 2019-08-06machine: Implement safety checks....Jakob L. Kreuze 2019-08-06machine: Rename 'system' field....Jakob L. Kreuze 2019-07-26guix system: Add 'reconfigure' module....Jakob L. Kreuze 2019-07-18machine: Fix typo....Tobias Geerinckx-Rice 2019-07-06gnu: Add machine type for deployment specifications....Jakob L. Kreuze