aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-14 17:51:48 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:45 +0200
commite8a1b10c272794f8380c4ddc221797c10b1f7cb2 (patch)
tree5f51ad2a406a05f1ada615fea27e9f11489b5d36 /gnu
parentcfd67d36b53f920a43efe3716a1d670127310a27 (diff)
downloadguix-e8a1b10c272794f8380c4ddc221797c10b1f7cb2.tar.gz
guix-e8a1b10c272794f8380c4ddc221797c10b1f7cb2.zip
gnu: make-bootstrap: Fix cross-compilation of ‘%glibc-stripped’.
Previously, ‘guix build bootstrap-tarballs --target=aarch64-linux-gnu’ or similar would construct a cross-libc where ‘%current-target-system’ is set. This would lead to a failure in the ‘add-cross-binutils-to-PATH’ phase, which assumes that ‘%current-target-system’ is #f; indeed, ‘cross-libc’ already returns a cross libc and so ‘%current-target-system’ must be set to #f. * gnu/packages/make-bootstrap.scm (%glibc-stripped)[inputs]: Move libc to… [native-inputs]: … here. Change-Id: Ifbf5e519ba3198940f4de4a36075d5302e923172
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d5b6b818b3..679aa46d60 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -448,19 +448,20 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(make-stripped-libc (assoc-ref %outputs "out")
(assoc-ref %build-inputs "libc")
(assoc-ref %build-inputs "kernel-headers")))))
- (inputs `(("kernel-headers"
- ,(if (or (and (%current-target-system)
- (target-hurd? (%current-target-system)))
- (string-suffix? "-hurd" (%current-system)))
- gnumach-headers
- linux-libre-headers))
- ("libc" ,(let ((target (%current-target-system)))
- (if target
- (glibc-for-bootstrap
- (parameterize ((%current-target-system #f))
- (cross-libc target)))
- glibc)))))
- (native-inputs '())
+ (native-inputs
+ `(("libc" ,(let ((target (%current-target-system)))
+ (if target
+ (glibc-for-bootstrap
+ (parameterize ((%current-target-system #f))
+ (cross-libc target)))
+ glibc)))))
+ (inputs
+ `(("kernel-headers"
+ ,(if (or (and (%current-target-system)
+ (target-hurd? (%current-target-system)))
+ (string-suffix? "-hurd" (%current-system)))
+ gnumach-headers
+ linux-libre-headers))))
(propagated-inputs '())
;; Only one output.