aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-11-19 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-11-19 01:00:00 +0100
commite87845ee2dfd5c7ef5be7acf96813987900986e6 (patch)
treebca4c8c01abf1b4f9077c83fbf2d3813c4b14b48 /gnu
parent109a2485d7a76cfade54fbb408bf3c2e84376c47 (diff)
downloadguix-e87845ee2dfd5c7ef5be7acf96813987900986e6.tar.gz
guix-e87845ee2dfd5c7ef5be7acf96813987900986e6.zip
gnu: turbostat: Use G-expressions.
* gnu/packages/linux.scm (turbostat)[arguments]: Rewrite as G-expressions. Change-Id: I5e2cf484692cda608d0144f4b35c63770301aadd
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c4f005ea67..4df8135a78 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6618,17 +6618,17 @@ by hand is no trivial task: @command{tmon} aims to make it understandable.")
(source (package-source linux-libre))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-subdirectory
- (lambda _
- (chdir "tools/power/x86/turbostat")
- #t))
- (delete 'configure)))) ; no configure script
+ (list
+ #:tests? #f ;no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "tools/power/x86/turbostat")))
+ (delete 'configure)))) ;no configure script
(inputs
(list libcap))
(supported-systems '("i686-linux" "x86_64-linux"))