aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:37:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:55 +0200
commite7d87d53aa5078539763b4f8447a501988956776 (patch)
tree780f76738615d6dee1ee8389b8b202ee79f5c0c3 /gnu
parent1771c6812b2e958c7d197312d620eafad0ddee2b (diff)
downloadguix-e7d87d53aa5078539763b4f8447a501988956776.tar.gz
guix-e7d87d53aa5078539763b4f8447a501988956776.zip
gnu: Add texlive-tikz-mirror-lens.
* gnu/packages/tex.scm (texlive-tikz-mirror-lens): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f284921ecd..660aa63549 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4580,6 +4580,27 @@ styles @code{on behind layer}, @code{on above layer}, @code{on glass layer} as
an option to a @code{scope} environment.")
(license license:lppl1.3+)))
+(define-public texlive-tikz-mirror-lens
+ (package
+ (name "texlive-tikz-mirror-lens")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-mirror-lens/"
+ "tex/latex/tikz-mirror-lens/")
+ (base32
+ "0sddmlki3bdd9js9vs1m1haqcdk3g1ji086jp1h4nfw6dy1s6y56")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-mirror-lens")
+ (synopsis "Spherical mirrors and lenses in TikZ")
+ (description
+ "This package allows the automatic drawing of the image of objects in
+spherical mirrors and lenses from the data of the focus, from the position and
+height of the object. It calculates the position and height of the image, and
+also displays the notable rays.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")