aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-07-30 13:36:37 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:42 +0000
commite6dd1f411d16f34be0f32a854573c32324b724ff (patch)
treebd663022bee15f3225facf0b5babfd4f7aea44dd /gnu
parent0ce36a9cf36be8782c65375240d30958816b1df4 (diff)
downloadguix-e6dd1f411d16f34be0f32a854573c32324b724ff.tar.gz
guix-e6dd1f411d16f34be0f32a854573c32324b724ff.zip
guix: pyproject-build-system: Default configure-flags to empty dictionary.
PEP 517 specifies it should be a dictionary and thus meson-python cannot handle an empty list. Fixes: <https://issues.guix.gnu.org/62781> * guix/build-system/pyproject.scm (lower): Change default of configure-flags. * gnu/packages/build-tools.scm (meson-python)[arguments]: Remove #:build-backend, which was a workaround for this bug. [native-inputs]: Remove python-p~a-build and python-wheel, which are not required when using the default build system. Change-Id: I240ced5c88cf55cbee0d6005d7657bfb6b653b12
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index b5bc299287..20106437b1 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -344,10 +344,7 @@ resembles Python.")
"0vyjhjabvm41hqijifk33idbdl62i76kfyf884f9rs29rpp77nzx"))))
(build-system pyproject-build-system)
(arguments
- ;; The project is configured to use itself to build ('mesonpy') and fails;
- ;; use another PEP 517 build system.
- (list #:build-backend "setuptools.build_meta"
- #:test-flags #~(list "tests"
+ (list #:test-flags #~(list "tests"
;; The test_pep518 tries to install
;; dependencies from the network using pip.
"-k" "not test_pep518")
@@ -368,10 +365,7 @@ resembles Python.")
python-typing-extensions
python-wheel))
(native-inputs
- (list python-pypa-build
- python-wheel
-
- ;; For tests.
+ (list ;; For tests.
git-minimal/pinned
patchelf
pkg-config