aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-07 14:55:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-08 18:41:35 +0200
commite56b07663c5f6e174a85309f2d00194d38cae782 (patch)
tree4bf86f3237e5a0c4a9b0bd9b22b2943acf59b882 /gnu
parent684c718e6a2fe47ea0f44f112cc2edf40df6a158 (diff)
downloadguix-e56b07663c5f6e174a85309f2d00194d38cae782.tar.gz
guix-e56b07663c5f6e174a85309f2d00194d38cae782.zip
gnu: Add python-pytest-cram.
* gnu/packages/python-check.scm (python-pytest-cram): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 14be55054f..af0e5be28b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -127,6 +127,26 @@ written in pure Python.")
interfaces with pytest.")
(license license:expat)))
+(define-public python-pytest-cram
+ (package
+ (name "python-pytest-cram")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-cram" version))
+ (sha256
+ (base32
+ "0405ymmrsv6ii2qhq35nxfjkb402sdb6d13xnk53jql3ybgmiqq0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-cram python-pytest))
+ (home-page "https://github.com/tbekolay/pytest-cram")
+ (synopsis "Run cram tests with pytest.")
+ (description "Cram tests command line applications; Pytest tests Python
+applications. @code{pytest-cram} tests Python command line applications by
+letting you write your Python API tests with pytest, and your command line
+tests in cram.")
+ (license license:expat)))
+
(define-public python-pytest-csv
(package
(name "python-pytest-csv")