aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-16 11:24:23 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:03 +0200
commite312bce54340022a1e55dee55b8a46b3b0dfb908 (patch)
tree8850f0d2fb6231ab261ac29db9278f403cecc406 /gnu
parenta0d74866abddd1f90cb073d7a59acd74f9df0063 (diff)
downloadguix-e312bce54340022a1e55dee55b8a46b3b0dfb908.tar.gz
guix-e312bce54340022a1e55dee55b8a46b3b0dfb908.zip
gnu: python-certifi: Ungraft.
* gnu/packages/python-crypto.scm (python-certifi): Ungraft and apply source snippet directly. (python-certifi/fixed): Remove variable. Change-Id: I6778ebcc3ef23dab1776d3876b9179d332a126e5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 86a826b7ed..3a7f53abee 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -472,27 +472,12 @@ for example, for recording or replaying web content.")
(package
(name "python-certifi")
(version "2022.6.15")
- (replacement python-certifi/fixed)
(source (origin
(method url-fetch)
(uri (pypi-uri "certifi" version))
(sha256
(base32
- "03c2l11lgljx0kz17cvdc4hlc3p1594ajdih9zq0a4dig285mj44"))))
- (build-system python-build-system)
- (arguments '(#:tests? #f)) ;no tests
- (home-page "https://certifi.io/")
- (synopsis "Python CA certificate bundle")
- (description
- "Certifi is a Python library that contains a CA certificate bundle, which
-is used by the Requests library to verify HTTPS requests.")
- (license license:asl2.0)))
-
-(define python-certifi/fixed
- (package
- (inherit python-certifi)
- (source (origin
- (inherit (package-source python-certifi))
+ "03c2l11lgljx0kz17cvdc4hlc3p1594ajdih9zq0a4dig285mj44"))
(snippet
#~(begin
(delete-file "certifi/cacert.pem")
@@ -521,7 +506,15 @@ def where() -> str:
def contents() -> str:
with open(where(), \"r\", encoding=\"ascii\") as data:
- return data.read()")))))))))
+ return data.read()")))))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (home-page "https://certifi.io/")
+ (synopsis "Python CA certificate bundle")
+ (description
+ "Certifi is a Python library that contains a CA certificate bundle, which
+is used by the Requests library to verify HTTPS requests.")
+ (license license:asl2.0)))
(define-public python-cryptography-vectors
(package