aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-31 04:17:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:58 +0200
commite2ad36d0747238382d3cdfe0e3b71e68d429f3cc (patch)
tree20461b3a833ddeb7c10b4f06acf87ac0aa183225 /gnu
parentf233efa74d9978afd398e332adbbc09f1906171d (diff)
downloadguix-e2ad36d0747238382d3cdfe0e3b71e68d429f3cc.tar.gz
guix-e2ad36d0747238382d3cdfe0e3b71e68d429f3cc.zip
gnu: emacs-expand-region: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-expand-region)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a4bf7feb2b..539ae7ee28 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2207,13 +2207,13 @@ mode, which displays information about Elasticsearch clusters.")
(version "0.11.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/magnars/expand-region.el"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magnars/expand-region.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "08dy1f411sh9wwww53rjw80idcf3vpki6ba2arl4hl5jcw9651g0"))))
+ (base32 "0h40dhc3kn8fq86xnwi5lz7ql8my8737y7wkqr897p15y90swr35"))))
(build-system emacs-build-system)
(home-page "https://github.com/magnars/expand-region.el")
(synopsis "Increase selected region by semantic units")