aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:00:33 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:03 +0100
commite25cd3335bbba7e23c99031634f1b69ac913547f (patch)
tree4a3f89fb9e314d39c4f07d1f520bddc7613ca3b5 /gnu
parent609db1de0a133b579be44522d88861ba36ede632 (diff)
downloadguix-e25cd3335bbba7e23c99031634f1b69ac913547f.tar.gz
guix-e25cd3335bbba7e23c99031634f1b69ac913547f.zip
gnu: Add rust-windows-i686-msvc-0.42.
* gnu/packages/crates-io.scm (rust-windows-i686-msvc-0.42): New variable. (rust-windows-i686-msvc-0.36): Inherit from RUST-WINDOWS-I686-MSVC-0.42. (rust-windows-i686-msvc-0.32): Inherit from RUST-WINDOWS-I686-MSVC-0.36. (rust-windows-i686-msvc-0.28): Inherit from RUST-WINDOWS-I686-MSVC-0.32. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm118
1 files changed, 59 insertions, 59 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 76cab0b529..cf5b0cb9a5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -67888,65 +67888,6 @@ crate.")
crate.")
(license (list license:expat license:asl2.0))))
-(define-public rust-windows-i686-msvc-0.28
- (package
- (name "rust-windows-i686-msvc")
- (version "0.28.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "windows_i686_msvc" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0r0z8s1wcdwd20azsdfilf2a6bz68xkavl990wy64hyc8f51bmai"))))
- (build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
- (home-page "https://github.com/microsoft/windows-rs")
- (synopsis "Code gen support for the windows crate")
- (description "This package provides code gen support for the windows
-crate.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-windows-i686-msvc-0.36
- (package
- (name "rust-windows-i686-msvc")
- (version "0.36.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "windows_i686_msvc" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "097h2a7wig04wbmpi3rz1akdy4s8gslj5szsx8g2v0dj91qr3rz2"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t))
- (home-page "https://github.com/microsoft/windows-rs")
- (synopsis "Code gen support for the windows crate")
- (description "This package provides code gen support for the windows
-crate.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-windows-i686-msvc-0.32
- (package
- (name "rust-windows-i686-msvc")
- (version "0.32.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "windows_i686_msvc" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0wj1wi01fc8hrasbakjcq8y5a7ynw9l2mcw08svmsq823axi2v0l"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t))
- (home-page "https://github.com/microsoft/windows-rs")
- (synopsis "Code gen support for the windows crate")
- (description "This package provides code gen support for the windows
-crate.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-windows-aarch64-gnullvm-0.42
(package
(name "rust-windows-aarch64-gnullvm")
@@ -68085,6 +68026,65 @@ crate.")
(base32
"12hx7qpsjg9p7jggfcplqa3mf1mzr7k7s5ybzqwg1zmg4fn2aizm"))))))
+(define-public rust-windows-i686-msvc-0.42
+ (package
+ (name "rust-windows-i686-msvc")
+ (version "0.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ii2hrsdif2ms79dfiyfzm1n579jzj42ji3fpsxd57d3v9jjzhc4"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-i686-msvc-0.36
+ (package
+ (inherit rust-windows-i686-msvc-0.42)
+ (name "rust-windows-i686-msvc")
+ (version "0.36.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "097h2a7wig04wbmpi3rz1akdy4s8gslj5szsx8g2v0dj91qr3rz2"))))))
+
+(define-public rust-windows-i686-msvc-0.32
+ (package
+ (inherit rust-windows-i686-msvc-0.36)
+ (name "rust-windows-i686-msvc")
+ (version "0.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wj1wi01fc8hrasbakjcq8y5a7ynw9l2mcw08svmsq823axi2v0l"))))))
+
+(define-public rust-windows-i686-msvc-0.28
+ (package
+ (inherit rust-windows-i686-msvc-0.32)
+ (name "rust-windows-i686-msvc")
+ (version "0.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r0z8s1wcdwd20azsdfilf2a6bz68xkavl990wy64hyc8f51bmai"))))))
+
(define-public rust-windows-implement-0.32
(package
(name "rust-windows-implement")